x265-vl.spec 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124
  1. %global commit 5e604833c5aa
  2. Summary: H.265/HEVC encoder library
  3. Summary(ja): H.265/HEVC エンコーダライブラリ
  4. Name: x265
  5. Version: 1.4
  6. Release: 2%{?_dist_release}
  7. Group: System Environment/Libraries
  8. URL: http://x265.org/
  9. Source0: https://bitbucket.org/multicoreware/x265/get/%{version}.tar.bz2
  10. # fix pkgconfig file installation path
  11. Patch0: x265-pc-path.patch
  12. # link test binaries with shared library
  13. Patch1: x265-test-shared.patch
  14. # build with -fPIC on arm and i686, too
  15. Patch2: x265-pic.patch
  16. # source/Lib/TLibCommon - BSD
  17. # source/Lib/TLibEncoder - BSD
  18. # everything else - GPLv2+
  19. License: GPLv2+ and BSD
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. BuildRequires: cmake
  22. BuildRequires: yasm
  23. %description
  24. The primary objective of x265 is to become the best H.265/HEVC encoder
  25. available anywhere, offering the highest compression efficiency and the
  26. highest performance on a wide variety of hardware platforms.
  27. This package contains the command line encoder and the shared library.
  28. %package devel
  29. Summary: H.265/HEVC encoder library development files
  30. Summary(ja): H.265/HEVC エンコーダライブラリの開発用ファイル
  31. Group: Development/Libraries
  32. Requires: %{name} = %{version}-%{release}
  33. %description devel
  34. The primary objective of x265 is to become the best H.265/HEVC encoder
  35. available anywhere, offering the highest compression efficiency and the
  36. highest performance on a wide variety of hardware platforms.
  37. This package contains the shared library development files.
  38. %prep
  39. %setup -q -n multicoreware-%{name}-%{commit}
  40. %patch0 -p1 -b .p
  41. # tests are crashing on x86 if linked against shared libx265
  42. %ifnarch i686
  43. %patch1 -p1 -b .ts
  44. %endif
  45. %patch2 -p1 -b .pic
  46. # f=doc/uncrustify/drag-uncrustify.bat
  47. # tr -d '\r' < ${f} > ${f}.unix && \
  48. # touch -r ${f} ${f}.unix && \
  49. # %__mv ${f}.unix ${f} || exit 1
  50. %build
  51. %cmake -G "Unix Makefiles" \
  52. -DCMAKE_SKIP_RPATH:BOOL=YES \
  53. -DENABLE_TESTS:BOOL=ON \
  54. source
  55. %__make %{?_smp_mflags}
  56. %install
  57. %__make DESTDIR=%{buildroot} install
  58. %__rm %{buildroot}%{_libdir}/libx265.a || exit 1
  59. # %__install -Dpm644 COPYING %{buildroot}%{_pkgdocdir}/COPYING
  60. %check
  61. LD_LIBRARY_PATH=$(pwd) test/PoolTest
  62. LD_LIBRARY_PATH=$(pwd) test/TestBench
  63. exit 0
  64. %post -p /sbin/ldconfig
  65. %postun -p /sbin/ldconfig
  66. %files
  67. %{_bindir}/x265
  68. # %dir %{_pkgdocdir}
  69. # %{_pkgdocdir}/COPYING
  70. %doc COPYING
  71. %{_libdir}/libx265.so.35
  72. %files devel
  73. %doc doc/*
  74. %{_includedir}/x265.h
  75. %{_includedir}/x265_config.h
  76. %{_libdir}/libx265.so
  77. %{_libdir}/pkgconfig/x265.pc
  78. %changelog
  79. * Sat Feb 7 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4-2
  80. - added Group tag
  81. * Fri Jan 2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.4-1
  82. - new upstream release
  83. - initial build based on RPM Fusion rawhide
  84. * Sun Aug 17 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-5
  85. - don't include contributor agreement in doc
  86. - make sure /usr/share/doc/x265 is owned
  87. - add a comment noting which files are BSD-licenced
  88. * Fri Aug 08 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-4
  89. - don't create bogus soname (patch by Xavier)
  90. * Thu Jul 17 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-3
  91. - fix tr call to remove DOS EOL
  92. - build the library with -fPIC on arm and i686, too
  93. * Sun Jul 13 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-2
  94. - use version in source URL
  95. - update License tag
  96. - fix EOL in drag-uncrustify.bat
  97. - don't link test binaries with shared binary on x86 (segfault)
  98. * Thu Jul 10 2014 Dominik Mierzejewski <rpm@greysector.net> 1.2-1
  99. - initial build
  100. - fix pkgconfig file install location
  101. - link test binaries with shared library