git-vl.spec 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821
  1. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  2. %define emacsen_pkgdir /usr/lib/emacsen-common/packages
  3. # Pass --without docs to rpmbuild if you don't want the documentation
  4. Name: git
  5. Version: 1.9.2
  6. Release: 1%{?_dist_release}
  7. Summary: Core git tools
  8. Summary(ja): Core git ツール
  9. License: GPLv2
  10. Group: Development/Tools
  11. URL: http://git-scm.com/
  12. Source: http://git-core.googlecode.com/files/%{name}-%{version}.tar.bz2
  13. Source1: vine-default-git.el
  14. Source2: git.xinetd
  15. Source3: git.conf.httpd
  16. Source4: gitweb.conf.in
  17. Source10: %{name}-install.sh
  18. Source11: %{name}-remove.sh
  19. Source12: git-init.el
  20. Patch0: git-1.5-gitweb-home-link.patch
  21. # Security
  22. # none
  23. BuildRequires: zlib-devel >= 1.2, openssl-devel, curl-devel,
  24. BuildRequires: expat-devel, gettext, asciidoc
  25. BuildRequires: pcre-devel
  26. BuildRequires: xmlto
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  28. Requires: perl-Git = %{version}-%{release}
  29. Requires: zlib
  30. Provides: git-core = %{version}-%{release}
  31. Obsoletes: git-core <= 1.5.4.3
  32. Vendor: Project Vine
  33. Distribution: Vine Linux
  34. Packager: iwaim
  35. %description
  36. Git is a fast, scalable, distributed revision control system with an
  37. unusually rich command set that provides both high-level operations
  38. and full access to internals.
  39. The git rpm installs the core tools with minimal dependencies. To
  40. install all git packages, including tools for integrating with other
  41. SCMs, install the git-all meta-package.
  42. %package all
  43. Summary: Meta-package to pull in all git tools
  44. Summary(ja): すべての git ツール
  45. Group: Development/Tools
  46. Requires: git = %{version}-%{release}
  47. Requires: git-svn = %{version}-%{release}
  48. Requires: git-cvs = %{version}-%{release}
  49. %if "%{?_dist_release}" != "vl4"
  50. Requires: git-arch = %{version}-%{release}
  51. %endif
  52. Requires: git-email = %{version}-%{release}
  53. Requires: gitk = %{version}-%{release}
  54. Requires: git-gui = %{version}-%{release}
  55. Requires: perl-Git = %{version}-%{release}
  56. Requires: emacs-git = %{version}-%{release}
  57. Requires: git-contrib = %{version}-%{release}
  58. Obsoletes: git <= 1.5.4.3
  59. %description all
  60. Git is a fast, scalable, distributed revision control system with an
  61. unusually rich command set that provides both high-level operations
  62. and full access to internals.
  63. This is a dummy package which brings in all subpackages.
  64. %package daemon
  65. Summary: Git protocol daemon
  66. Summary(ja): Git プロトコルデーモン
  67. Group: Development/Tools
  68. Requires: git = %{version}-%{release}
  69. %description daemon
  70. The git daemon for supporting git:// access to git repositories
  71. %package -n gitweb
  72. Summary: Simple web interface to git repositories
  73. Summary(ja): git リポジトリへのシンプルな Web インタフェース
  74. Group: Development/Tools
  75. Requires: git = %{version}-%{release}
  76. %description -n gitweb
  77. Simple web interface to track changes in git repositories
  78. %package svn
  79. Summary: Git tools for importing Subversion repositories
  80. Summary(ja): Subversion リポジトリを git へインポートするためのツール
  81. Group: Development/Tools
  82. Requires: git = %{version}-%{release}, subversion, perl(Term::ReadKey)
  83. Requires: perl(SVN::Core)
  84. %description svn
  85. Git tools for importing Subversion repositories.
  86. %package cvs
  87. Summary: Git tools for importing CVS repositories
  88. Summary(ja): CVS リポジトリを git へインポートするためのツール
  89. Group: Development/Tools
  90. Requires: git = %{version}-%{release}, cvs, cvsps
  91. %description cvs
  92. Git tools for importing CVS repositories.
  93. %package contrib
  94. Summary: Git contrib tools
  95. Group: Development/Tools
  96. Requires: git = %{version}-%{release}
  97. %description contrib
  98. Git contrib tools
  99. %if "%{?_dist_release}" != "vl4"
  100. %package arch
  101. Summary: Git tools for importing Arch repositories
  102. Summary(ja): Arch リポジトリを git へインポートするためのツール
  103. Group: Development/Tools
  104. Requires: git = %{version}-%{release}, tla
  105. %description arch
  106. Git tools for importing Arch repositories.
  107. %endif
  108. %package email
  109. Summary: Git tools for sending email
  110. Summary(ja): Eメールを送るための git ツール
  111. Group: Development/Tools
  112. Requires: git = %{version}-%{release}, perl-Git = %{version}-%{release}
  113. %description email
  114. Git tools for sending email.
  115. %package gui
  116. Summary: Git GUI tool
  117. Summary(ja): Git の GUI ツール
  118. Group: Development/Tools
  119. Requires: git = %{version}-%{release}, tk
  120. %description gui
  121. Git GUI tool.
  122. %package -n gitk
  123. Summary: Git revision tree visualiser
  124. Summary(ja): Git リビジョンツリー可視化ツール
  125. Group: Development/Tools
  126. Requires: git = %{version}-%{release}, tk
  127. %description -n gitk
  128. Git revision tree visualiser.
  129. %package -n perl-Git
  130. Summary: Perl interface to Git
  131. Summary(ja): Git の perl インタフェース
  132. Group: Development/Libraries
  133. Requires: git = %{version}-%{release}, perl(Error)
  134. %if "%{?_dist_release}" == "vl4"
  135. Requires: perl = %(rpm -q --qf '%%{epoch}:%%{version}' perl)
  136. %else
  137. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  138. %endif
  139. #BuildRequires: perl(Error), perl(ExtUtils::MakeMaker)
  140. %description -n perl-Git
  141. Perl interface to Git.
  142. %package -n emacs-git
  143. Summary: Git version control system support for Emacs
  144. Summary(ja): Emacs の Git サポート
  145. Group: Applications/Editors
  146. Requires: git = %{version}-%{release}, emacsen-common
  147. %description -n emacs-git
  148. %{summary}.
  149. %package devel
  150. Summary: Header files for git-core
  151. Summary(ja): git-core 用ヘッダファイル
  152. Group: Development/Libraries
  153. %description devel
  154. Header files for git-core.
  155. %prep
  156. %setup -q
  157. %patch0 -p1
  158. %__mv contrib/diff-highlight/README contrib/diff-highlight/README.diff-highlight
  159. # Filter bogus perl requires
  160. cat << \EOF > %{name}-req
  161. #!/bin/sh
  162. %{__perl_requires} $* |\
  163. sed -e '/perl(packed-refs)/d'
  164. EOF
  165. %global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
  166. chmod +x %{__perl_requires}
  167. %build
  168. make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" \
  169. ETC_GITCONFIG=/etc/gitconfig \
  170. USE_LIBPCRE=1 \
  171. GITWEB_PROJECTROOT=/var/lib/git \
  172. gitwebdir=/var/www/git \
  173. prefix=%{_prefix} all %{!?_without_docs: doc}
  174. %install
  175. rm -rf $RPM_BUILD_ROOT
  176. make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
  177. prefix=%{_prefix} mandir=%{_mandir} \
  178. ETC_GITCONFIG=/etc/gitconfig \
  179. USE_LIBPCRE=1 \
  180. NO_PYTHON=1 \
  181. GITWEB_PROJECTROOT=/var/lib/git \
  182. gitwebdir=/var/www/git \
  183. INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
  184. # perl-Git
  185. # Error.pm provide by perl-Error package
  186. rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
  187. # emacs-git
  188. mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
  189. #mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
  190. #mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
  191. mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
  192. mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
  193. # install el files
  194. install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
  195. # install vine-default file
  196. install -m644 %{SOURCE1} %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
  197. # install script( bytecompile el and install elc , remove )
  198. %_installemacsenscript git %{SOURCE10}
  199. %_removeemacsenscript git %{SOURCE11}
  200. mkdir -p $RPM_BUILD_ROOT/%{_var}/lib/git
  201. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
  202. install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
  203. perl -p \
  204. -e "s|\@GITCOREDIR\@|%{_libexecdir}/git-core|g;" \
  205. -e "s|\@BASE_PATH\@|%{_var}/lib/git|g;" \
  206. %{SOURCE3} > %{buildroot}%{_sysconfdir}/xinetd.d/git
  207. ## for gitweb sub package
  208. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
  209. install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
  210. sed "s|@PROJECTROOT@|%{_var}/lib/git|g" \
  211. %{SOURCE4} > %{buildroot}%{_sysconfdir}/gitweb.conf
  212. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  213. find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
  214. find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
  215. (find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@) > bin-man-doc-files
  216. (find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
  217. %if %{!?_without_docs:1}0
  218. (find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
  219. %else
  220. rm -rf $RPM_BUILD_ROOT%{_mandir}
  221. %endif
  222. mkdir -p $RPM_BUILD_ROOT/srv/git
  223. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
  224. install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
  225. install -m 755 contrib/diff-highlight/diff-highlight $RPM_BUILD_ROOT%{_bindir}/
  226. # header files and lib
  227. install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
  228. install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
  229. install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
  230. install libgit.a $RPM_BUILD_ROOT%{_libdir}
  231. install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
  232. %clean
  233. rm -rf $RPM_BUILD_ROOT
  234. %post -n emacs-git
  235. # bytecompile and install
  236. if [ "$1" = 2 ]; then
  237. %_emacsenPackageRemove git
  238. fi
  239. %_addemacsenlist git
  240. %_emacsenPackageInstall git
  241. %preun -n emacs-git
  242. if [ "$1" = 0 ]; then
  243. %_emacsenPackageRemove git
  244. %_removeemacsenlist git
  245. fi
  246. %files -f bin-man-doc-files
  247. %defattr(-,root,root)
  248. %{_bindir}/git
  249. %{_bindir}/git-receive-pack
  250. %{_bindir}/git-upload-archive
  251. %{_bindir}/git-upload-pack
  252. %{_bindir}/git-shell
  253. %{_datadir}/git-core/
  254. %doc README COPYING Documentation/*.txt contrib/hooks
  255. %{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
  256. %{!?_without_docs: %doc Documentation/howto Documentation/technical}
  257. %{_sysconfdir}/bash_completion.d
  258. %files svn
  259. %defattr(-,root,root)
  260. %{_libexecdir}/git-core/*svn*
  261. %doc Documentation/*svn*.txt
  262. %{!?_without_docs: %{_mandir}/man1/*svn*.1*}
  263. %{!?_without_docs: %doc Documentation/*svn*.html }
  264. %files cvs
  265. %defattr(-,root,root)
  266. %doc Documentation/*git-cvs*.txt
  267. %{_bindir}/git-cvsserver
  268. %{_libexecdir}/git-core/*cvs*
  269. %{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
  270. %{!?_without_docs: %doc Documentation/*git-cvs*.html }
  271. %files contrib
  272. %defattr(-,root,root)
  273. %doc diff-highlight/README.diff-highlight
  274. %{_bindir}/diff-highlight
  275. %if "%{?_dist_release}" != "vl4"
  276. %files arch
  277. %defattr(-,root,root)
  278. %doc Documentation/git-archimport.txt
  279. %{_libexecdir}/git-core/git-archimport
  280. %{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
  281. %{!?_without_docs: %doc Documentation/git-archimport.html }
  282. %endif
  283. %files email
  284. %defattr(-,root,root)
  285. %doc Documentation/*email*.txt
  286. %{_libexecdir}/git-core/*email*
  287. %{!?_without_docs: %{_mandir}/man1/*email*.1*}
  288. %{!?_without_docs: %doc Documentation/*email*.html }
  289. %files gui
  290. %defattr(-,root,root)
  291. %{_libexecdir}/git-core/git-gui*
  292. %{_libexecdir}/git-core/git-citool
  293. %{_datadir}/git-gui/
  294. %{!?_without_docs: %{_mandir}/man1/git-gui.1*}
  295. %{!?_without_docs: %doc Documentation/git-gui.html}
  296. %{!?_without_docs: %{_mandir}/man1/git-citool.1*}
  297. %{!?_without_docs: %doc Documentation/git-citool.html}
  298. %files -n gitk
  299. %defattr(-,root,root)
  300. %doc Documentation/*gitk*.txt
  301. %{_bindir}/gitk
  302. %{_datadir}/gitk
  303. %{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
  304. %{!?_without_docs: %doc Documentation/*gitk*.html }
  305. %files -n perl-Git -f perl-files
  306. %defattr(-,root,root)
  307. %files -n emacs-git
  308. %defattr(-,root,root)
  309. %{_datadir}/emacs/site-lisp/git
  310. #%{_libdir}/emacsen-common/packages/install/git
  311. #%{_libdir}/emacsen-common/packages/remove/git
  312. %{emacsen_pkgdir}/install/git
  313. %{emacsen_pkgdir}/remove/git
  314. %files daemon
  315. %defattr(-,root,root)
  316. %{_var}/lib/git
  317. %{_libexecdir}/git-core/git-daemon
  318. %config(noreplace)%{_sysconfdir}/xinetd.d/git
  319. /srv/git
  320. %files -n gitweb
  321. %defattr(-,root,root)
  322. %doc gitweb/README
  323. /var/www/git/
  324. %config(noreplace)%{_sysconfdir}/gitweb.conf
  325. %config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
  326. %files devel
  327. %defattr(644,root,root,755)
  328. %{_includedir}/git
  329. %{_libdir}/libgit.a
  330. %{_libdir}/libgit_xdiff.a
  331. %files all
  332. # No files for you!
  333. %changelog
  334. * Sun Dec 29 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.5.2-1
  335. - update to 1.8.5.2
  336. * Thu Nov 28 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.4.4-1
  337. - update to 1.8.4.4
  338. - new sub package: contrib
  339. * Fri Feb 8 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.3-1
  340. - new upstream release
  341. * Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.2-1
  342. - new upstream release
  343. * Thu Jan 17 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.1-1
  344. - new upstream release
  345. * Thu Jan 3 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1-1
  346. - new upstream release
  347. * Wed Dec 12 2012 IWAI, Masaharu <iwai@alib.jp> 1.8.0.2-1
  348. - new upstream release
  349. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0.1-1
  350. - new upstream release
  351. * Mon Oct 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
  352. - new upstream release
  353. - enable libpcre support, add BR: pcre-devel
  354. - add /etc/gitweb.conf
  355. - add /var/lib/git for PROJECTROOT
  356. * Mon Sep 3 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.12-1
  357. - new upstream release
  358. * Fri May 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.2-1
  359. - new upstream release
  360. * Sat May 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.1-1
  361. - new upstream release
  362. * Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.4.2-1
  363. - new upstream release
  364. * Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-2vl6
  365. - build with perl 5.12.3
  366. * Mon Jan 10 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-1
  367. - new upstream release
  368. - build with openssl 1.0.0c for VineSeed
  369. * Sat Jan 1 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.4-1
  370. - new upstream release: include security fix: CVE-2010-3906
  371. * Fri Oct 1 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.3.1-1
  372. - new upstream release
  373. - drop CVE-2010-2542 patch (Patch100): upstream fixed
  374. - apply vine-default
  375. - rename Source1: git-init.el -> vine-default-git.el
  376. - add new git-init.el file (Source12)
  377. - update git-install.sh
  378. - update %%build and %%install section for gitweb subpackage
  379. - add README in gitweb subpackage
  380. * Tue Sep 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.1-2
  381. - add Patch100 for fix CVE-2010-2542 (BOF in is_git_directory)
  382. * Wed Jun 9 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.1-1
  383. - new upstream release
  384. - fix git-daemon path in git.xinetd: <BTS:VineLinux:919>
  385. - disable building of unused python remote helper libs
  386. * Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
  387. - new upstream release with security fix
  388. - drop patch10 (included in new release)
  389. * Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
  390. - new upstream release
  391. - add patch10 git daemon extra arg parsing fix
  392. * Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
  393. - fix install script for Emacs Lisp: <BTS:VineLinux:685>
  394. - update git-install.sh (Source10) using contributed patch
  395. * Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
  396. - new upstream release
  397. * Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
  398. - delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
  399. - spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
  400. - fix summary and description in daemon sub package
  401. * Sun Feb 1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
  402. - drop Error.pm: provide by perl-Error package
  403. * Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
  404. - new upstream relase
  405. - update URL tag
  406. - add Requires: perl(SVN::Core) for svn subpackage
  407. * Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
  408. - add git-shell in git package
  409. - do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
  410. * Mon Jan 5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
  411. - added BuildRequires: xmlto
  412. * Mon Jan 5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
  413. - new upstream release
  414. - add devel subpackage (see [wishes:0165])
  415. * Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
  416. - new upstream release
  417. * Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
  418. - new upstream release
  419. * Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
  420. - new upstream release
  421. * Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
  422. - use %%emacsen_pkgdir macro
  423. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
  424. - new upstream release
  425. * Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6.4-1
  426. - initial build for Vine Linux
  427. * Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
  428. - git-1.5.6.4
  429. * Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
  430. - git-1.5.6
  431. * Tue Jun 3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
  432. - use tar.bz2 instead of tar.gz
  433. * Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
  434. - git-1.5.5.3
  435. * Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
  436. - git-1.5.5.2
  437. * Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
  438. - git-1.5.5.1
  439. * Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
  440. - git-1.5.5
  441. * Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
  442. - Remove the last two requires on git-core.
  443. * Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
  444. - Remove a patch that's already upstream.
  445. * Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
  446. - git-1.5.4.5
  447. * Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
  448. - Own /etc/bash_completion.d in case bash-completion isn't installed.
  449. * Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
  450. - Include the sample hooks from contrib/hooks as docs (bug 321151).
  451. - Install the bash completion script from contrib (bug 433255).
  452. - Include the html docs in the 'core' package again (bug 434271).
  453. * Wed Mar 19 2008 James Bowes 1.5.4.4-2
  454. - Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
  455. * Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
  456. - git-1.5.4.4
  457. * Mon Mar 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
  458. - rebuild for new perl (again)
  459. * Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
  460. - Do not silently overwrite /etc/httpd/conf.d/git.conf
  461. * Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
  462. - git-1.5.4.3
  463. - Include Kristian Høgsberg's changes to rename git-core to
  464. git and git to git-all.
  465. * Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
  466. - git-1.5.4.2
  467. * Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
  468. - Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
  469. gitweb rss feeds point be commitdiffs instead of commit
  470. * Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
  471. - git-1.5.4.1
  472. * Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
  473. - rebuild for new perl
  474. * Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
  475. - Add BuidRequires on gettext.
  476. * Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
  477. - git-1.5.4
  478. * Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
  479. - git-1.5.3.8
  480. * Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
  481. - Have git metapackage require explicit versions (bug 247214)
  482. * Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
  483. - git-1.5.3.7
  484. * Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
  485. - git-1.5.3.6
  486. - git-core requires perl(Error) (bug 367861)
  487. - git-svn requires perl(Term:ReadKey) (bug 261361)
  488. - git-email requires perl-Git (bug 333061)
  489. * Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
  490. - git-Perl requires Error package
  491. * Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
  492. - git-1.5.3.4
  493. * Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
  494. - git-1.5.3.3
  495. * Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
  496. - git-1.5.3.2
  497. * Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
  498. - Include git-gui and git-citool docs
  499. * Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
  500. - git-1.5.3.1-1
  501. * Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
  502. - git-1.5.2.5-1
  503. * Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
  504. - git-1.5.2.4-1
  505. * Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
  506. - Add git-daemon and gitweb packages
  507. * Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
  508. - Add emacs-git package (#235431)
  509. * Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
  510. - git-1.5.2.2
  511. * Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
  512. - git-1.5.2.1
  513. * Tue May 13 2007 Quy Tonthat <qtonthat@gmail.com>
  514. - Added lib files for git-gui
  515. - Added Documentation/technical (As needed by Git Users Manual)
  516. * Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
  517. - Added howto files
  518. * Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
  519. - git-1.5.0.6
  520. * Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
  521. - git-1.5.0.5
  522. * Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
  523. - git-1.5.0.3
  524. * Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
  525. - BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
  526. * Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
  527. - git-1.5.0.2
  528. * Mon Feb 13 2007 Nicolas Pitre <nico@cam.org>
  529. - Update core package description (Git isn't as stupid as it used to be)
  530. * Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
  531. - Add git-gui and git-citool.
  532. * Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
  533. - no need to install manpages executable (bz 216790)
  534. - use bytes for git-cvsserver
  535. * Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
  536. - git-1.4.4.2
  537. * Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
  538. - rebuild against the new curl
  539. * Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
  540. - git-1.4.2.4
  541. * Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
  542. - git-1.4.2.3
  543. * Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
  544. - git-1.4.2.1
  545. * Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
  546. - git-1.4.2
  547. * Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
  548. - git-1.4.1
  549. * Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
  550. - git-1.4.0
  551. * Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
  552. - git-1.3.3
  553. - enable git-email building, prereqs have been relaxed
  554. * Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
  555. - git-1.3.2
  556. * Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
  557. - git-1.3.1
  558. * Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
  559. - git-1.3.0
  560. * Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
  561. - git-1.2.6
  562. * Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
  563. - git-1.2.5
  564. * Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
  565. - git-1.2.4
  566. * Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
  567. - git-1.2.3
  568. * Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
  569. - git-1.2.2
  570. * Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
  571. - git-1.2.1
  572. * Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
  573. - git-1.2.0
  574. * Tue Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
  575. - git-1.1.6
  576. * Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
  577. - git-1.1.4
  578. * Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
  579. - git-1.1.2
  580. * Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
  581. - git-1.1.1
  582. * Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
  583. - Update to latest git-1.1.0 (drop git-email for now)
  584. - Now creates multiple packages:
  585. - git-core, git-svn, git-cvs, git-arch, gitk
  586. * Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
  587. - Change subpackage names to git-<name> instead of git-core-<name>
  588. - Create empty root package which brings in all subpackages
  589. - Rename git-tk -> gitk
  590. * Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
  591. - zlib dependency fix
  592. - Minor cleanups from split
  593. - Move arch import to separate package as well
  594. * Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
  595. - Move programs with non-standard dependencies (svn, cvs, email)
  596. into separate packages
  597. * Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
  598. - parallelize build
  599. - COPTS -> CFLAGS
  600. * Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
  601. - update to 0.99.6
  602. * Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  603. - Linus noticed that less is required, added to the dependencies
  604. * Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  605. - Updated dependencies
  606. - Don't assume manpages are gzipped
  607. * Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
  608. - drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
  609. - use RPM_OPT_FLAGS in spec file, drop patch0
  610. * Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
  611. - use dist tag to differentiate between branches
  612. - use rpm optflags by default (patch0)
  613. - own %{_datadir}/git-core/
  614. * Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
  615. - update spec file to fix Buildroot, Requires, and drop Vendor
  616. * Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  617. - Redid the description
  618. - Cut overlong make line, loosened changelog a bit
  619. - I think Junio (or perhaps OSDL?) should be vendor...
  620. * Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
  621. - Add the man pages, and the --without docs build option
  622. * Wed Jul 7 2005 Chris Wright <chris@osdl.org>
  623. - initial git spec file