polkit-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437
  1. %bcond_with systemd
  2. Summary: PolicyKit Authorization Framework
  3. Summary(ja): PolicyKit 認証フレームワーク
  4. Name: polkit
  5. Version: 0.118
  6. Release: 2%{?_dist_release}%{?with_systemd:.systemd}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: LGPLv2+
  11. URL: https://www.freedesktop.org/wiki/Software/polkit
  12. Source0: https://www.freedesktop.org/software/%{name}/releases/%{name}-%{version}.tar.gz
  13. Patch0: polkit-0.115-elogind.patch
  14. Patch1000: CVE-2021-3560.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. BuildRequires: glib2-devel
  17. BuildRequires: expat-devel
  18. BuildRequires: pam-devel
  19. BuildRequires: mozjs78-devel
  20. BuildRequires: gtk-doc
  21. BuildRequires: intltool
  22. BuildRequires: gobject-introspection-devel
  23. %if %{with systemd}
  24. BuildRequires: systemd-devel
  25. %{?systemd_requires}
  26. %else
  27. BuildRequires: elogind-devel
  28. %endif
  29. Requires: dbus
  30. Obsoletes: PolicyKit <= 0.10
  31. Provides: PolicyKit = 0.11
  32. Obsoletes: polkit-desktop-policy < 0.103
  33. Provides: polkit-desktop-policy = 0.103
  34. %if %{with systemd}
  35. %{?systemd_requires}
  36. %endif
  37. %description
  38. PolicyKit is a toolkit for defining and handling authorizations.
  39. It is used for allowing unprivileged processes to speak to privileged
  40. processes.
  41. %package devel
  42. Summary: Development files for PolicyKit
  43. Summary(ja): PolicyKit の開発用ファイル
  44. Group: programming
  45. Requires: %name = %{version}-%{release}
  46. Requires: %name-docs = %{version}-%{release}
  47. Requires: pkgconfig
  48. Requires: glib2-devel
  49. %description devel
  50. Development files for PolicyKit.
  51. %package docs
  52. Summary: Development documentation for PolicyKit
  53. Summary(ja): PolicyKit の開発用ドキュメント
  54. Group: documentation
  55. Requires: %name-devel = %{version}-%{release}
  56. Requires: gtk-doc
  57. %description docs
  58. Development documentation for PolicyKit.
  59. %debug_package
  60. %prep
  61. %setup -q
  62. %if !%{with systemd}
  63. %patch0 -p1
  64. %endif
  65. %patch1000 -p1
  66. %build
  67. autoreconf -vif
  68. %configure \
  69. --with-os-type=redhat \
  70. --enable-gtk-doc \
  71. --disable-static \
  72. --libexecdir=%{_libexecdir}/polkit-1 \
  73. --enable-introspection \
  74. %if %{with systemd}
  75. --enable-libsystemd-login=yes \
  76. %else
  77. --enable-libelogind=yes \
  78. %endif
  79. --enable-examples
  80. make %{?_smp_mflags}
  81. %install
  82. rm -rf $RPM_BUILD_ROOT
  83. make install DESTDIR=$RPM_BUILD_ROOT
  84. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  85. rm -f $RPM_BUILD_ROOT%{_libdir}/polkit-1/extensions/*.la
  86. %find_lang polkit-1
  87. %clean
  88. rm -rf $RPM_BUILD_ROOT
  89. %pre
  90. groupadd -g 27 -r polkitd >/dev/null 2>&1 || :
  91. useradd -u 27 -g polkitd -r -d '/' -s /sbin/nologin -c "User for polkitd" polkitd >/dev/null 2>&1 || :
  92. exit 0
  93. %post
  94. %if %{with systemd}
  95. %systemd_post polkit.service
  96. %endif
  97. %if %{with systemd}
  98. %preun
  99. %systemd_preun polkit.service
  100. %endif
  101. %postun
  102. %if %{with systemd}
  103. %systemd_postun_with_restart polkit.service
  104. %endif
  105. %files -f polkit-1.lang
  106. %defattr(-,root,root,-)
  107. %license COPYING
  108. %doc NEWS README
  109. %{_libdir}/lib*.so.*
  110. %{_datadir}/man/man1/*
  111. %{_datadir}/man/man8/*
  112. %{_datadir}/dbus-1/system-services/*
  113. %if %{with systemd}
  114. %{_unitdir}/polkit.service
  115. %endif
  116. %dir %{_datadir}/polkit-1/
  117. %dir %{_datadir}/polkit-1/actions
  118. %attr(0700,polkitd,root) %dir %{_datadir}/polkit-1/rules.d
  119. %{_datadir}/polkit-1/actions/org.freedesktop.policykit.policy
  120. %dir %{_sysconfdir}/polkit-1
  121. %{_sysconfdir}/polkit-1/rules.d/50-default.rules
  122. %attr(0700,polkitd,root) %dir %{_sysconfdir}/polkit-1/rules.d
  123. %{_sysconfdir}/dbus-1/system.d/org.freedesktop.PolicyKit1.conf
  124. %{_sysconfdir}/pam.d/polkit-1
  125. %{_bindir}/pkaction
  126. %{_bindir}/pkcheck
  127. %{_bindir}/pkttyagent
  128. %dir %{_prefix}/lib/polkit-1
  129. %{_prefix}/lib/polkit-1/polkitd
  130. %{_libdir}/girepository-1.0/*.typelib
  131. # see upstream docs for why these permissions are necessary
  132. %attr(4755,root,root) %{_bindir}/pkexec
  133. %attr(4755,root,root) %{_prefix}/lib/polkit-1/polkit-agent-helper-1
  134. %files devel
  135. %defattr(-,root,root,-)
  136. %{_libdir}/lib*.so
  137. %{_libdir}/pkgconfig/*.pc
  138. %{_datadir}/gir-1.0/*.gir
  139. %{_includedir}/*
  140. %{_bindir}/pk-example-frobnicate
  141. %{_datadir}/polkit-1/actions/org.freedesktop.policykit.examples.pkexec.policy
  142. %dir %{_datadir}/gettext
  143. %dir %{_datadir}/gettext/its
  144. %{_datadir}/gettext/its/*
  145. %files docs
  146. %defattr(-,root,root,-)
  147. %{_datadir}/gtk-doc/html/*
  148. %changelog
  149. * Sat Jun 12 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.118-2
  150. - added Patch1000 to fix CVE-2021-3560.
  151. - dropped ldconfig scriptlets.
  152. * Wed Feb 24 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.118-1
  153. - new upstream release.
  154. * Fri Aug 07 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.117-1
  155. - new upstream release.
  156. - dropped Patch1-3: fixed in upstream.
  157. * Sat Jul 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.116-2
  158. - added systemd support (disabled as default).
  159. - imported Patch1-3 from rawhide.
  160. * Tue Mar 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.116-1
  161. - new upstream release.
  162. * Fri Jan 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.115-2
  163. - really enabled elogind.
  164. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.115-1
  165. - new upstream release.
  166. - enabled elogind: ConsoleKit is obsolete.
  167. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.112-2
  168. - new upstream release
  169. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.112-1
  170. - new upstream release
  171. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.110-1
  172. - new upstream release
  173. * Thu Sep 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.107-1
  174. - new upstream release
  175. - add BuildRequires: js-devel
  176. - remove BuildRequires: eggdbus-devel
  177. - remove polkit-desktop-policy subpackage (based on fedora)
  178. - historical changelogs are following:
  179. * Tue May 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.105-1
  180. - new upstream release
  181. * Sat Feb 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.104-1
  182. - new upstream release
  183. * Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.102-1
  184. - new upstream release
  185. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.99-1
  186. - new upstream release
  187. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.96-2
  188. - build with rpm-4.8.1-1 for pkg-config file
  189. * Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.96-1
  190. - update to 0.96
  191. - BR: eggdbus-devel >= 0.6
  192. * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.95-0.2.git20090913
  193. - remove Obsoletes:/Provides: PolicyKit*
  194. * Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.95-0.1.git20090913
  195. - initial build for Vine Linux
  196. * Wed Jul 11 2012 David Zeuthen <davidz@redhat.com> 0.107-1%{?dist}
  197. - Update to upstream release 0.107
  198. * Fri Jun 29 2012 David Zeuthen <davidz@redhat.com> 0.106-2%{?dist}
  199. - Add forgotten Requires(pre): shadow-utils
  200. * Thu Jun 07 2012 David Zeuthen <davidz@redhat.com> 0.106-1%{?dist}
  201. - Update to upstream release 0.106
  202. - Authorizations are no longer controlled by .pkla files - from now
  203. on, use the new .rules files described in the polkit(8) man page
  204. * Tue Apr 24 2012 David Zeuthen <davidz@redhat.com> 0.105-1%{?dist}
  205. - Update to upstream release 0.105
  206. - Nuke patches that are now upstream
  207. - Change 'PolicyKit' to 'polkit' in summary and descriptions
  208. * Thu Mar 08 2012 David Zeuthen <davidz@redhat.com> 0.104-6%{?dist}
  209. - Don't leak file descriptors (bgo #671486)
  210. * Mon Feb 13 2012 Matthias Clasen <mclasen@redhat.com> - 0.104-5%{?dist}
  211. - Make the -docs subpackage noarch
  212. * Mon Feb 06 2012 David Zeuthen <davidz@redhat.com> 0.104-4%{?dist}
  213. - Set error if we cannot obtain a PolkitUnixSession for a given PID (#787222)
  214. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.104-3
  215. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  216. * Tue Jan 03 2012 David Zeuthen <davidz@redhat.com> 0.104-2%{?dist}
  217. - Nuke the ConsoleKit run-time requirement
  218. * Tue Jan 03 2012 David Zeuthen <davidz@redhat.com> 0.104-1%{?dist}
  219. - Update to upstream release 0.104
  220. - Force usage of systemd (instead of ConsoleKit) for session tracking
  221. * Tue Dec 06 2011 David Zeuthen <davidz@redhat.com> 0.103-1%{?dist}
  222. - Update to upstream release 0.103
  223. - Drop upstreamed patch
  224. - Drop Fedora-specific policy, it is now upstream (fdo #41008)
  225. * Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.102-3
  226. - Rebuilt for glibc bug#747377
  227. * Tue Oct 18 2011 David Zeuthen <davidz@redhat.com> 0.102-2%{?dist}
  228. - Add patch to neuter the annoying systemd behavior where stdout/stderr
  229. is sent to the system logs
  230. * Thu Aug 04 2011 David Zeuthen <davidz@redhat.com> 0.102-1
  231. - Update to 0.102 release
  232. * Fri May 13 2011 Bastien Nocera <bnocera@redhat.com> 0.101-7
  233. - Allow setting the pretty hostname without a password for wheel,
  234. change matches systemd in git
  235. * Mon May 2 2011 Matthias Clasen <mclasen@redhat.com> - 0.101-6
  236. - Update the action id of the datetime mechanism
  237. * Tue Apr 19 2011 David Zeuthen <davidz@redhat.com> - 0.101-5
  238. - CVE-2011-1485 (#697951)
  239. * Tue Mar 22 2011 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.101-4
  240. - Also allow org.kde.kcontrol.kcmclock.save without password for wheel
  241. * Thu Mar 17 2011 David Zeuthen <davidz@redhat.com> - 0.101-3
  242. - Fix typo in pkla file (thanks notting)
  243. * Thu Mar 17 2011 David Zeuthen <davidz@redhat.com> - 0.101-2
  244. - Nuke desktop_admin_r and desktop_user_r groups - just use the
  245. wheel group instead (#688363)
  246. - Update the set of configuration directives that gives users
  247. in the wheel group extra privileges
  248. * Thu Mar 03 2011 David Zeuthen <davidz@redhat.com> - 0.101-1
  249. - New upstream version
  250. * Mon Feb 21 2011 David Zeuthen <davidz@redhat.com> - 0.100-1
  251. - New upstream version
  252. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.98-7
  253. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  254. * Fri Jan 28 2011 Matthias Clasen <mclasen@redhat.com> - 0.98-6
  255. - Own /usr/libexec/polkit-1
  256. * Sun Nov 14 2010 Matthias Clasen <mclasen@redhat.com> - 0.98-5
  257. - Enable introspection
  258. * Thu Sep 02 2010 David Zeuthen <davidz@redhat.com> - 0.98-4
  259. - Fix #629515 in a way that doesn't require autoreconf
  260. * Thu Sep 02 2010 David Zeuthen <davidz@redhat.com> - 0.98-2
  261. - Include polkitagentenumtypes.h (#629515)
  262. * Mon Aug 23 2010 Matthias Clasen <mclasen@redhat.com> - 0.98-1
  263. - Update to upstream release 0.98
  264. - Co-own /usr/share/gtk-doc (#604410)
  265. * Wed Aug 18 2010 Matthias Clasen <mclasen@redhat.com> - 0.97-5
  266. - Rebuid to work around bodhi limitations
  267. * Wed Aug 18 2010 Matthias Clasen <mclasen@redhat.com> - 0.97-4
  268. - Fix a ConsoleKit interaction bug
  269. * Fri Aug 13 2010 David Zeuthen <davidz@redhat.com> - 0.97-3
  270. - Add a patch to make pkcheck(1) work the way libvirtd uses it (#623257)
  271. - Require GLib >= 2.25.12 instead of 2.25.11
  272. - Ensure polkit-gnome packages earlier than 0.97 are not used with
  273. these packages
  274. * Mon Aug 09 2010 David Zeuthen <davidz@redhat.com> - 0.97-2
  275. - Rebuild
  276. * Mon Aug 09 2010 David Zeuthen <davidz@redhat.com> - 0.97-1
  277. - Update to 0.97. This release contains a port from EggDBus to the
  278. GDBus code available in recent GLib releases.
  279. * Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 0.96-1
  280. - Update to 0.96
  281. - Disable introspection support for the time being
  282. * Fri Nov 13 2009 David Zeuthen <davidz@redhat.com> - 0.95-2
  283. - Rebuild
  284. * Fri Nov 13 2009 David Zeuthen <davidz@redhat.com> - 0.95-1
  285. - Update to 0.95
  286. - Drop upstreamed patches
  287. * Tue Oct 20 2009 Matthias Clasen <mclasen@redhat.com> - 0.95-0.git20090913.3
  288. - Fix a typo in pklocalauthority(8)
  289. * Mon Sep 14 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913.2
  290. - Refine how Obsolete: is used and also add Provides: (thanks Jesse
  291. Keating and nim-nim)
  292. * Mon Sep 14 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913.1
  293. - Add bugfix for polkit_unix_process_new_full() (thanks Bastien Nocera)
  294. - Obsolete old PolicyKit packages
  295. * Sun Sep 13 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913
  296. - Update to git snapshot
  297. - Drop upstreamed patches
  298. - Turn on GObject introspection
  299. - Don't delete desktop_admin_r and desktop_user_r groups when
  300. uninstalling polkit-desktop-policy
  301. * Fri Sep 11 2009 David Zeuthen <davidz@redhat.com> - 0.94-4
  302. - Add some patches from git master
  303. - Sort pkaction(1) output
  304. - Bug 23867 – UnixProcess vs. SystemBusName aliasing
  305. * Thu Aug 13 2009 David Zeuthen <davidz@redhat.com> - 0.94-3
  306. - Add desktop_admin_r and desktop_user_r groups along with a first cut
  307. of default authorizations for users in these groups.
  308. * Wed Aug 12 2009 David Zeuthen <davidz@redhat.com> - 0.94-2
  309. - Disable GObject Introspection for now as it breaks the build
  310. * Wed Aug 12 2009 David Zeuthen <davidz@redhat.com> - 0.94-1
  311. - Update to upstream release 0.94
  312. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.93-3
  313. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  314. * Mon Jul 20 2009 David Zeuthen <davidz@redhat.com> - 0.93-2
  315. - Rebuild
  316. * Mon Jul 20 2009 David Zeuthen <davidz@redhat.com> - 0.93-1
  317. - Update to 0.93
  318. * Tue Jun 09 2009 David Zeuthen <davidz@redhat.com> - 0.92-3
  319. - Don't make docs noarch (I *heart* multilib)
  320. - Change license to LGPLv2+
  321. * Mon Jun 08 2009 David Zeuthen <davidz@redhat.com> - 0.92-2
  322. - Rebuild
  323. * Mon Jun 08 2009 David Zeuthen <davidz@redhat.com> - 0.92-1
  324. - Update to 0.92 release
  325. * Wed May 27 2009 David Zeuthen <davidz@redhat.com> - 0.92-0.git20090527
  326. - Update to 0.92 snapshot
  327. * Mon Feb 9 2009 David Zeuthen <davidz@redhat.com> - 0.91-1
  328. - Initial spec file.