self-build-broadcom-wl-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167
  1. %define pkgname broadcom-wl
  2. %define name self-build-%{pkgname}
  3. %define oname hybrid-portsrc
  4. %define over %(echo %{version} | tr . _)
  5. %define downloadurl https://docs.broadcom.com/docs-and-downloads/docs/linux_sta
  6. %ifarch %{ix86}
  7. %define source0path %{downloadurl}/hybrid-v35-nodebug-pcoem-%{over}.tar.gz
  8. %endif
  9. %ifarch x86_64
  10. %define source0path %{downloadurl}/hybrid-v35_64-nodebug-pcoem-%{over}.tar.gz
  11. %endif
  12. Summary: Package to automatically build %{pkgname} rpm package
  13. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  14. Name: %{name}
  15. Version: 6.30.223.271
  16. Release: 2%{?_dist_release}
  17. Source0: %{pkgname}-vl.spec
  18. Source1: blacklist-broadcom.conf
  19. Source100: broadcom-wl-kernel318.patch
  20. License: Freeware and GPLv2 with exception
  21. Group: Restricted Software
  22. Requires(pre): self-build-setup >= 0.7-1
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. ExclusiveArch: %{ix86} x86_64
  25. %description
  26. Proprietary hybrid driver for Broadcom wireless adapters.
  27. If you install this package, it automaticaly downloads source
  28. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  29. And the created rpm packages are automatically installed
  30. if installation is executed by apt-get command or synaptic
  31. package manager.
  32. [Note]
  33. This package requires many other packages to compile
  34. targetsoftware. So it consume more disk space than usual.
  35. Also installation takes logner time because of compilation.
  36. (This will take a few minutes to quarter or half of an hour,
  37. depends on building environment)
  38. [About self-build package]
  39. For some kind of software, distributing of binary package
  40. may viorate the patent or law. Therefore we chose self-build
  41. packge, create binary package on your machine, for such kind
  42. of softwares instead of distributing binary package.
  43. Please obey the national law when you use the created binary
  44. packages. And if you want to use the softwares using patented
  45. thechnology, it may be required to get a permission, make an
  46. agreement or purchas a license. Please consider it with your
  47. purpose or way of use and take appropriate action.
  48. %description -l ja
  49. Broadcom ワイヤレスアダプタ用のプロプライエタリドライバです。
  50. このパッケージをインストールすると、自動的にソースコードを
  51. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  52. の rpm パッケージを作成します。
  53. また apt-get コマンドや synaptic パッケージマネージャから実行
  54. した場合は、作成された rpm パッケージのインストールも自動的に
  55. 行います。
  56. [注意]
  57. コンパイルに必要な多くの関連パッケージを要求するので通常より
  58. ディスクの領域を多く消費します。
  59. またインストール時にコンパイルを行うため、通常より時間がかか
  60. る場合があります。(環境にもよりますが数分から数十分程度)
  61. [self-build パッケージについて]
  62. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  63. 違反する可能性があるものがあります。その為、このような問題が
  64. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  65. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  66. ジという方法を採っています。
  67. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  68. アのライセンス、および利用する国の各種法令に従ってください。
  69. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  70. センスの購入などが必要となる場合がありますので、利用する目的
  71. や形態に応じて各自で判断し適切な対応を取ってください。
  72. %install
  73. rm -rf %{buildroot}
  74. install -d %{buildroot}%{_datadir}/%{name}
  75. install -m 644 %{SOURCE1} %{buildroot}%{_datadir}/%{name}
  76. #install -m 644 %{SOURCE2} %{buildroot}%{_datadir}/%{name}
  77. sed -e 's|##VERSION##|%{version}|g' -e 's|##RELEASE##|%{release}|g' \
  78. %{SOURCE0} > %{buildroot}%{_datadir}/%{name}/%{pkgname}-vl.spec
  79. %{__install} -m 644 %{SOURCE100} \
  80. $RPM_BUILD_ROOT/%{_datadir}/%{name}
  81. %clean
  82. rm -rf %{buildroot}
  83. %posttrans
  84. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{source0path}"
  85. /usr/lib/rpm/pre-allocate-rpm.sh dkms-%{pkgname}-%{version}-%{release}
  86. %files
  87. %defattr(-,root,root)
  88. %{_datadir}/%{name}/*
  89. %changelog
  90. * Wed Nov 22 2017 Toshiaki Ara <ara_t@384.jp> 6.30.223.271-2
  91. - change download URL
  92. * Sat Oct 31 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.30.223.271-1
  93. - new upstream release.
  94. - dropped SOURCE100.
  95. - fixed date of changelog.
  96. * Sun Aug 2 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.30.223.248-2
  97. - added Source100 to build with kernel 3.18
  98. * Wed Nov 19 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.30.223.248-1
  99. - new upstream release
  100. - dropped SOURCE2
  101. - updated dmks.conf
  102. * Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.100.82.112-1
  103. - new upstream release.
  104. - dropped an old patch.
  105. - added SOURCE2 to compile for kernel-3.2.x.
  106. * Tue Oct 4 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.100.82.38-3
  107. - update SOURCE1 (see: http://www.broadcom.com/docs/linux_sta/bcma.txt)
  108. * Sun Aug 14 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.100.82.38-2
  109. - add a patch to fix build failure on linux > 2.6.37
  110. * Sat Jan 01 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.100.82.38-1
  111. - new upstream release
  112. * Tue Aug 17 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.60.48.36-2
  113. - add Source2 to fix build failure on kernel >= 2.6.35
  114. (https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/590924)
  115. * Tue Aug 17 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.60.48.36-1
  116. - new upstream release
  117. * Wed Sep 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9.3-1
  118. - new upstream release
  119. * Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-3
  120. - fix to ensure Source0 has correct version/release numbers
  121. * Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-2
  122. - add ExclusiveArch
  123. * Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-1
  124. - initial build for Vine Linux