pcre2-vl.spec 9.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: Perl-compatible regular expression library
  3. Summary(ja): Perl 互換の正規表現ライブラリ
  4. Name: pcre2
  5. Version: 10.44
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: inagaki
  11. License: BSD
  12. URL: https://www.pcre.org/
  13. Source0: https://github.com/PhilipHazel/pcre2/releases/download/pcre2-%{version}/pcre2-%{version}.tar.bz2
  14. # Upstream thinks RPATH is good idea.
  15. Patch0: pcre2-10.31-multilib.patch
  16. # https://github.com/PCRE2Project/pcre2/commit/57906628d7babd27c01eb1c085d3e0cdd512189a
  17. Patch100: 57906628d7babd27c01eb1c085d3e0cdd512189a.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: pkgconfig(zlib)
  20. BuildRequires: bzip2-devel
  21. BuildRequires: libedit-devel
  22. # New libtool to get rid of rpath
  23. BuildRequires: autoconf, automake, libtool
  24. %description
  25. Perl-compatible regular expression library.
  26. PCRE has its own native API, but a set of "wrapper" functions that are based on
  27. the POSIX API are also supplied in the library libpcreposix. Note that this
  28. just provides a POSIX calling interface to PCRE: the regular expressions
  29. themselves still follow Perl syntax and semantics. The header file
  30. for the POSIX-style functions is called pcreposix.h.
  31. %package devel
  32. Summary: Development files for %{name}
  33. Summary(ja): %{name} の開発用ファイル
  34. Group: programming
  35. Requires: %{name} = %{version}-%{release}
  36. %description devel
  37. Development files (Headers, libraries for static linking, etc) for %{name}.
  38. %package -n compat32-%{name}
  39. Summary: Perl-compatible regular expression library
  40. Summary(ja): Perl 互換の正規表現ライブラリ
  41. Group: system,legacy
  42. %description -n compat32-%{name}
  43. Perl-compatible regular expression library.
  44. PCRE has its own native API, but a set of "wrapper" functions that are based on
  45. the POSIX API are also supplied in the library libpcreposix. Note that this
  46. just provides a POSIX calling interface to PCRE: the regular expressions
  47. themselves still follow Perl syntax and semantics. The header file
  48. for the POSIX-style functions is called pcreposix.h.
  49. %package -n compat32-%{name}-devel
  50. Summary: Development files for %{name}
  51. Summary(ja): %{name} の開発用ファイル
  52. Group: programming,legacy
  53. Requires: compat32-%{name} = %{version}-%{release}
  54. %description -n compat32-%{name}-devel
  55. Development files (Headers, libraries for static linking, etc) for %{name}.
  56. %debug_package
  57. %prep
  58. %setup -q
  59. # Get rid of rpath
  60. %patch0 -p1 -b .multilib
  61. %patch100 -p1 -b .bugfix
  62. # Because of rpath patch
  63. libtoolize --copy --force && autoreconf -vif
  64. # One contributor's name is non-UTF-8
  65. for F in ChangeLog; do
  66. iconv -f latin1 -t utf8 "$F" >"${F}.utf8"
  67. touch --reference "$F" "${F}.utf8"
  68. mv "${F}.utf8" "$F"
  69. done
  70. %build
  71. %configure \
  72. --enable-jit \
  73. --disable-static \
  74. --enable-utf8 \
  75. --enable-unicode-properties \
  76. --enable-pcregrep-libz \
  77. --enable-pcregrep-libbz2 \
  78. --enable-pcretest-libedit \
  79. --enable-pcre2-8 \
  80. --enable-pcre2-16 \
  81. --enable-pcre2-32
  82. make %{?_smp_mflags}
  83. %install
  84. rm -rf $RPM_BUILD_ROOT
  85. make install DESTDIR=$RPM_BUILD_ROOT
  86. rm -rf $RPM_BUILD_ROOT%{_datadir}/doc
  87. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  88. %check
  89. %ifarch s390 s390x ppc
  90. # larger stack is needed on s390, ppc
  91. ulimit -s 10240
  92. %endif
  93. make %{?_smp_mflags} check VERBOSE=yes
  94. %clean
  95. rm -rf $RPM_BUILD_ROOT
  96. %files
  97. %defattr(-,root,root)
  98. %license COPYING LICENCE
  99. %doc AUTHORS ChangeLog NEWS README
  100. %{_bindir}/pcre2grep
  101. %{_libdir}/*.so.*
  102. %{_mandir}/man1/pcre2grep.*
  103. %files devel
  104. %defattr(-,root,root)
  105. %doc doc/html/*
  106. %{_bindir}/pcre2-config
  107. %{_bindir}/pcre2test
  108. %{_includedir}/*
  109. %{_libdir}/*.so
  110. %{_libdir}/pkgconfig/*.pc
  111. %{_mandir}/man1/pcre2-config.*
  112. %{_mandir}/man1/pcre2test.*
  113. %{_mandir}/man3/*
  114. %if %{build_compat32}
  115. %files -n compat32-%{name}
  116. %defattr(-, root, root)
  117. %{_libdir}/*.so.*
  118. %files -n compat32-%{name}-devel
  119. %defattr(-, root, root)
  120. %{_libdir}/*.so
  121. %endif
  122. %changelog
  123. * Mon Jun 10 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.44-1
  124. - new upstream release.
  125. * Sat Feb 17 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.43-1
  126. - new upstream release.
  127. * Tue Dec 13 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.42-1
  128. - new upstream release.
  129. * Wed Dec 07 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.41-1
  130. - new upstream release.
  131. * Sat Apr 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.40-1
  132. - new upstream release.
  133. * Sat Oct 30 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.39-1
  134. - new upstream release.
  135. * Wed Oct 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.38-1
  136. - new upstream release.
  137. * Mon Jul 26 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.37-1
  138. - new upstream release.
  139. - dropped ldconfig scriptletes.
  140. * Mon Feb 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.36-1
  141. - new upstream release.
  142. * Thu Oct 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.35-1
  143. - new upstream release.
  144. * Sun Mar 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.34-1
  145. - new upstream release.
  146. * Sun May 20 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 10.31-1
  147. - new: pcre2 package
  148. - update multilib patch (Patch0)
  149. - drop unnecessary patch (Patch1)
  150. * Fri Jul 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.39-2
  151. - create comapt32 packages
  152. * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.39-1
  153. - new upstream release.
  154. - dropped Patch1000,1001: fixed in upstream.
  155. * Wed Mar 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.38-1
  156. - new upstream release.
  157. - removed Patch2,Patch3 (no longer needed).
  158. - added Patch1000 to fix CVE-2016-1283.
  159. * Sun Apr 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.36-1
  160. - new upstream release
  161. - added patches including security fix from Fedora (CVE-2014-8964)
  162. * Thu Nov 20 2014 Petr Pisar <ppisar@redhat.com> - 8.36-3
  163. - Fix CVE-2014-8964 (unused memory usage on zero-repeat assertion condition)
  164. (bug #1165626)
  165. * Fri Nov 07 2014 Petr Pisar <ppisar@redhat.com> - 8.36-2
  166. - Reset non-matched groups within capturing group up to forced match
  167. (bug #1161587)
  168. * Mon May 09 2011 Petr Pisar <ppisar@redhat.com> - 8.12-3
  169. - Fix typos in manual pages (bugs #675476, #675477)
  170. * Thu Sep 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.35-1
  171. - new upstream release
  172. - add --enable-pcre32 and --enable-pcretest-libedit
  173. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 8.31-1
  174. - new upstream release
  175. - add --enable-pcre16 --enable-pcre8 --enable-jit
  176. - API change
  177. - change includedir to /usr/include
  178. * Sat Sep 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.13-1
  179. - new upstream release
  180. * Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.12-1
  181. - new upstream release
  182. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 8.10-2
  183. - rebuilt with rpm-4.8.1 for pkg-config
  184. * Thu Aug 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.10-1
  185. - new upstream release
  186. * Mon May 10 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 8.02-1
  187. - new upstream release with security fix
  188. * Sat Feb 6 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.01-1
  189. - new upstream release
  190. * Sat Jan 16 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.00-1
  191. - new upstream release
  192. * Tue Jul 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.9-2
  193. - add --enable-unicode-properties to configure option
  194. * Wed Jun 10 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.9-1
  195. - new upstream release
  196. - added BR: zlib-devel, bzip2-devel
  197. - removed static libraries from devel package
  198. - added Packager tag
  199. * Sat Jan 24 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.8-1vl5
  200. - new upstream release
  201. - spec in UTF-8
  202. * Sun Jul 6 2008 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.7-1vl5
  203. - new upstream release
  204. * Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
  205. - use macro for Release
  206. * Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
  207. - apply new virsioning policy.
  208. - remove *.la
  209. * Thu Feb 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.6-0vl1
  210. - new upstream release
  211. * Wed Nov 7 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.4-0vl1
  212. - new upstream release
  213. * Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.2-0vl1
  214. - new upstream release
  215. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.6-0vl2
  216. - rebuild with new environment/toolchain
  217. * Wed Feb 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6-0vl1
  218. - new upstream release
  219. * Mon Sep 5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl2
  220. - added --enable-utf8 option
  221. * Sun Sep 4 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl1
  222. - new upstream release
  223. * Thu Jan 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0-0vl1
  224. - new upstream release
  225. - added Japanese summary
  226. * Sun Apr 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5-0vl1
  227. - new upstream release
  228. * Mon Oct 13 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.4-0vl1
  229. - new upstream release
  230. * Mon May 5 2003 Tomoya TAKA <taka@vinelinux.org> 4.1-0vl3
  231. - skip 'make check' on alpha
  232. * Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl2
  233. - change install section
  234. - change files section
  235. * Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl1
  236. - update to 4.1
  237. - add %{_bindir}/pcretest
  238. - add %doc AUTHORS COPYING ChangeLog INSTALL LICENCE NEWS README
  239. * Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.9-0vl2
  240. - rebuild with new toolchains
  241. * Sat Mar 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.9-0vl1
  242. - Update to 3.9
  243. * Wed Dec 26 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.7-0vl1
  244. - Update to 3.7
  245. * Sun Oct 14 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.5-0vl1
  246. - Update to 3.5
  247. * Wed Oct 10 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.4-2vl1
  248. - Build for VineSeed
  249. * Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.4-2
  250. - Move libpcre to /lib, grep uses it these days (#41104)
  251. * Wed Apr 18 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  252. - Move this to a separate package, used to be in kdesupport, but it's
  253. generally useful...