texlive-common-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205
  1. ## -*- coding: utf-8-unix -*-
  2. %bcond_with firstbuild
  3. %if %{?_dist_release} == "vl6"
  4. Provides: jadetex
  5. Obsoletes: jadetex tetex dvipdfmx xdvik xdvik-motif
  6. %endif
  7. %if %{?_dist_release} == "vl5"
  8. Provides: jadetex
  9. Conflicts: tetex dvipdfmx xdvik xdvik-motif jvf
  10. %endif
  11. Obsoletes: tetex-latex tetex-afm tetex-type1 tetex-devel
  12. Obsoletes: pTeX pLaTeX2e pLaTeX2e_Macros dvipsk
  13. Obsoletes: dvipdfm texmacro-aps
  14. Obsoletes: makejvf <= 1.1a
  15. Conflicts: task-texmacro-phys < 1.1
  16. %define tex_destdir %{_datadir}
  17. %define texmf %{tex_destdir}/texmf
  18. %define texlive_src %{tex_destdir}/texlive-sources
  19. %define build_tex_destdir %{buildroot}%{tex_destdir}
  20. %define build_texmf %{buildroot}%{texmf}
  21. %define exec_mktexlsr [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
  22. %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
  23. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
  24. ## NOTE: For only texlive-common, if %exec_fmtutil fails,
  25. ## we show the STDERR of %exec_fmtutil.
  26. %define exec_fmtutil [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null
  27. %define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
  28. %define vartexfonts %{_var}/lib/texmf
  29. %define __find_provides %{nil}
  30. %define __find_requires %{nil}
  31. %define __perl_provides %{nil}
  32. %define __perl_requires %{nil}
  33. Autoreq: 0
  34. Summary: Common base for all TeX Live packages
  35. Summary(ja): TeX Live パッケージの共通ベース
  36. Name: texlive-common
  37. Version: 2009
  38. Release: 6%{?_dist_release}
  39. License: distributable
  40. Group: Applications/Publishing
  41. URL: http://www.tug.org/texlive/
  42. Requires: texlive = %{version}
  43. Requires(pre,post): texlive = %{version}
  44. Requires: texlive-collection-basic = %{version}
  45. Requires(post): texlive-collection-basic = %{version}
  46. Requires: texlive-collection-latex = %{version}
  47. Requires(post): texlive-collection-latex = %{version}
  48. Requires: texlive-collection-latexrecommended = %{version}
  49. Requires(post): texlive-collection-latexrecommended = %{version}
  50. Requires: texlive-collection-fontsrecommended = %{version}
  51. Requires(post): texlive-collection-fontsrecommended = %{version}
  52. #### $ pdftex -ini -jobname=latex -progname=latex -translate-file=cp227.tcx *latex.ini
  53. ## dehypht-x-2009-06-19.tex
  54. Requires: texlive-collection-langgerman = %{version}
  55. Requires(post): texlive-collection-langgerman = %{version}
  56. ## catkoi
  57. Requires: texlive-collection-langcyrillic = %{version}
  58. Requires(post): texlive-collection-langcyrillic = %{version}
  59. #### $ xetex -ini -jobname=xelatex -progname=xelatex -etex xelatex.ini
  60. ## unicode-letters
  61. Requires: texlive-collection-xetex = %{version}
  62. Requires(post): texlive-collection-xetex = %{version}
  63. BuildArch: noarch
  64. Buildroot: %{_tmppath}/%{name}-%{version}-root
  65. Vendor: Project Vine
  66. Distribution: Vine Linux
  67. Packager: munepi
  68. %description
  69. The TeX Live software distribution offers a complete TeX system for a
  70. variety of Unix, Macintosh, Windows and other platforms. It
  71. encompasses programs for editing, typesetting, previewing and printing
  72. of TeX documents in many different languages, and a large collection
  73. of TeX macros and font libraries.
  74. The distribution includes extensive general documentation about TeX,
  75. as well as the documentation for the included software packages.
  76. This package is a virtual package
  77. to provide a common base for all TeX Live packages.
  78. %description -l ja
  79. TeX Live ソフトウェアディストリビューションは、
  80. さまざまな Unix, Macintosh, Windows、および
  81. 他のプラットホームに対して完全な TeX システムを提供します。
  82. 多くの異なった言語を含む TeX ドキュメントの
  83. 編集、組版、閲覧、印刷するためのプログラム、
  84. そして、TeX マクロやフォントライブラリの大きなコレクションを
  85. 同梱しています。
  86. このディストリビューションは
  87. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  88. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  89. このパッケージは TeX Live パッケージの共通ベースを
  90. 提供ための仮想パッケージです。
  91. %files
  92. %post
  93. %{exec_texhash}
  94. updmap_lock=%{texmf}/updmap.lock
  95. # The packages required texlive-common contained the following maps.
  96. (cat<<EOF
  97. MixedMap cm.map
  98. MixedMap cmextra.map
  99. MixedMap cyrillic.map
  100. Map euler.map
  101. MixedMap latxfont.map
  102. MixedMap symbols.map
  103. MixedMap cmtext-bsr-interpolated.map
  104. MixedMap mflogo.map
  105. Map charter.map
  106. Map fpls.map
  107. Map pazo.map
  108. Map utopia.map
  109. Map zpeu.map
  110. MixedMap eurosym.map
  111. Map lm.map
  112. Map marvosym.map
  113. Map pxfonts.map
  114. MixedMap rsfs.map
  115. Map qag.map
  116. Map qbk.map
  117. Map qcr.map
  118. Map qcs.map
  119. Map qhv.map
  120. Map qpl.map
  121. Map qtm.map
  122. Map qzc.map
  123. MixedMap tipa.map
  124. Map txfonts.map
  125. MixedMap wasy.map
  126. Map cmcyr.map
  127. EOF
  128. ) | while read maptype map; do
  129. %{exec_updmap} --listmaps 2>/dev/null | egrep -q "^#! ${maptype} ${map}" && \
  130. echo -n " " && \
  131. echo -n "Running updmap: enable ${map} ... " && \
  132. %{exec_updmap} --nomkmap --enable ${maptype} ${map} >/dev/null 2>&1 && \
  133. echo "done." && \
  134. touch ${updmap_lock}
  135. done
  136. echo -n " "
  137. echo -n "Running updmap ... " && %{exec_updmap} >/dev/null 2>&1 && echo "done."
  138. rm -f %{texmf}/updmap.lock
  139. echo -n " "
  140. echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
  141. exit 0
  142. # %postun
  143. # %{exec_texhash}
  144. # echo -n " "
  145. # echo -n "Running updmap ... " && %{exec_updmap} >/dev/null 2>&1 && echo "done."
  146. # echo -n " "
  147. # echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
  148. exit 0
  149. %changelog
  150. * Mon May 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
  151. - added Requires(post): for all requirements of texlive-collection-*
  152. - added Requires: texlive
  153. * Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
  154. - improved %%post
  155. - checked the maps containing Require(post) dependencies
  156. * Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
  157. - added Requires(post): texlive
  158. - changed Requires(pre): -> Requires(post): for all requirements
  159. * Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  160. - added to remove %%{texmf}/updmap.lock in %%post
  161. - When texlive-common is installed, this lock generating
  162. texlive-collection-* leaves.
  163. - dropped %%postun
  164. - added some comments for the definition of %%exec_fmtutil
  165. * Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  166. - changed Requires: -> Requires(pre): for all requirements
  167. - merged dependencies of Provides:/Obsoletes: tags from texlive-vl.spec
  168. * Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  169. - TeX Live 2009