gdb-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391
  1. Summary: A GNU source-level debugger for C, C++ and other languages.
  2. Summary(ja): C, C++ その他の言語用 GNU ソースレベルデバッガ
  3. Name: gdb
  4. Version: 7.2
  5. Release: 1%{?_dist_release}
  6. License: GPL
  7. Group: Development/Debuggers
  8. Source: ftp://sources.redhat.com/pub/gdb/releases/gdb-%{version}.tar.bz2
  9. Buildroot: %{_tmppath}/%{name}-%{version}-root
  10. URL: http://sources.redhat.com/gdb/
  11. BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo expat-devel
  12. Requires: install-info
  13. %description
  14. GDB, the GNU debugger, allows you to debug programs written in C, C++,
  15. and other languages, by executing them in a controlled fashion and
  16. printing their data.
  17. %description -l ja
  18. GDB (GNU デバッガ) は C, C++ その他の言語で書かれたプログラムのデバッグに
  19. 使うツールです.プログラムの実行を制御し,データを出力することができます.
  20. %prep
  21. %setup -q
  22. %build
  23. export CFLAGS="$RPM_OPT_FLAGS"
  24. rm -fr dejagnu tcl expect
  25. ./configure \
  26. --prefix=%{_prefix} \
  27. --sysconfdir=%{_sysconfdir} \
  28. --mandir=%{_mandir} \
  29. --infodir=%{_infodir} \
  30. %{_target_platform}
  31. make
  32. make info
  33. cp gdb/NEWS .
  34. %install
  35. rm -rf $RPM_BUILD_ROOT
  36. %makeinstall infodir=$RPM_BUILD_ROOT%{_infodir} prefix=$RPM_BUILD_ROOT%{_prefix}
  37. # install the gcore script in /usr/bin
  38. install -m755 $RPM_BUILD_DIR/gdb-%{version}/gdb/gdb_gcore.sh $RPM_BUILD_ROOT%{_bindir}/gcore
  39. # The above is broken, do this for now:
  40. #mkdir -p $RPM_BUILD_ROOT/%{_infodir}
  41. #cp `find -name "*.info*"` $RPM_BUILD_ROOT/%{_infodir}
  42. # These are part of binutils
  43. #rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  44. #rm -f $RPM_BUILD_ROOT%{_infodir}/dir.info*
  45. rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
  46. rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
  47. rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
  48. rm -r $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,iberty*,opcodes*}
  49. rm -f $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd.mo,opcodes.mo}
  50. rm -rf $RPM_BUILD_ROOT%{_includedir}
  51. %clean
  52. rm -rf $RPM_BUILD_ROOT
  53. %post
  54. [ -f %{_infodir}/annotate.info ] && /sbin/install-info %{_infodir}/annotate.info %{_infodir}/dir || :
  55. [ -f %{_infodir}/annotate.info.gz ] && /sbin/install-info %{_infodir}/annotate.info.gz %{_infodir}/dir || :
  56. [ -f %{_infodir}/gdb.info ] && /sbin/install-info %{_infodir}/gdb.info %{_infodir}/dir || :
  57. [ -f %{_infodir}/gdb.info.gz ] && /sbin/install-info %{_infodir}/gdb.info.gz %{_infodir}/dir || :
  58. [ -f %{_infodir}/gdbint.info ] && /sbin/install-info %{_infodir}/gdbint.info %{_infodir}/dir || :
  59. [ -f %{_infodir}/gdbint.info.gz ] && /sbin/install-info %{_infodir}/gdbint.info.gz %{_infodir}/dir || :
  60. [ -f %{_infodir}/stabs.info ] && /sbin/install-info %{_infodir}/stabs.info %{_infodir}/dir || :
  61. [ -f %{_infodir}/stabs.info.gz ] && /sbin/install-info %{_infodir}/stabs.info.gz %{_infodir}/dir || :
  62. %preun
  63. if [ $1 = 0 ]; then
  64. [ -f %{_infodir}/annotate.info ] && /sbin/install-info --delete %{_infodir}/annotate.info %{_infodir}/dir || :
  65. [ -f %{_infodir}/annotate.info.gz ] && /sbin/install-info --delete %{_infodir}/annotate.info.gz %{_infodir}/dir || :
  66. [ -f %{_infodir}/gdb.info ] && /sbin/install-info --delete %{_infodir}/gdb.info %{_infodir}/dir || :
  67. [ -f %{_infodir}/gdb.info.gz ] && /sbin/install-info --delete %{_infodir}/gdb.info.gz %{_infodir}/dir || :
  68. [ -f %{_infodir}/gdbint.info ] && /sbin/install-info --delete %{_infodir}/gdbint.info %{_infodir}/dir || :
  69. [ -f %{_infodir}/gdbint.info.gz ] && /sbin/install-info --delete %{_infodir}/gdbint.info.gz %{_infodir}/dir || :
  70. [ -f %{_infodir}/stabs.info ] && /sbin/install-info --delete %{_infodir}/stabs.info %{_infodir}/dir || :
  71. [ -f %{_infodir}/stabs.info.gz ] && /sbin/install-info --delete %{_infodir}/stabs.info.gz %{_infodir}/dir || :
  72. fi
  73. %files
  74. %defattr(-,root,root)
  75. %doc COPYING COPYING.LIB README NEWS
  76. %{_bindir}/*
  77. %{_mandir}/*/*
  78. %{_datadir}/gdb/syscalls
  79. %{_infodir}/annotate.info*
  80. %{_infodir}/gdb.info*
  81. %{_infodir}/gdbint.info*
  82. %{_infodir}/stabs.info*
  83. %exclude %{_infodir}/dir
  84. %ifarch x86_64
  85. %{_libdir}/libinproctrace.so
  86. %endif
  87. ## don't include the files in include, they are part of binutils
  88. #%{_includedir}/*
  89. #%{_infodir}/bfd.info*
  90. #%{_infodir}/configure.info*
  91. #%{_infodir}/standard.info*
  92. #%{_libdir}/*
  93. #%{_datadir}/locale/*/LC_MESSAGES/bfd.mo
  94. #%{_datadir}/locale/*/LC_MESSAGES/opcode.mo
  95. %changelog
  96. * Thu Apr 28 2011 Shu KONNO <owa@bg.wakwak.com> 7.2-1
  97. - updated gdb to 7.2
  98. * Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 7.0.1-1
  99. - updated gdb to 7.0.1
  100. - rebuilt with new environment
  101. * Sat Sep 13 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-1vl5
  102. - applied new versioning policy, spec in utf-8
  103. * Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.7.1-0vl4
  104. - rebuild with expat-2.0.1
  105. - add BuildRequires: expat-devel
  106. * Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl3
  107. - dropt %%{_localedir}/*/LC_MESSAGES/*.mo conflicts with binutils
  108. * Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl2
  109. - dropt %%{_libdir}/lib{bfd*,iberty*,opcodes*} conflicts with binutils-devel
  110. * Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl1
  111. - new upstream release
  112. * Wed Jul 12 2006 Shu KONNO <owa@bg.wakwak.com> 6.4.90-0vl1
  113. - new upstream release
  114. * Sat Dec 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0-0vl1
  115. - new upstream release
  116. * Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 5.2.1-4vl2
  117. - Oops, spec was written in Shift-JIS. Fixed.
  118. * Mon Nov 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-4vl1
  119. - based on 5.2.1-4 from Rawhide and built for Vine Linux
  120. * Fri Aug 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  121. - added mainframe patch from developerworks
  122. * Wed Aug 21 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-3
  123. - Add changelogs to the previous patch
  124. * Wed Aug 14 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-2
  125. - Add some patches from Elena Zannoni <ezannoni@redhat.com>
  126. * Tue Jul 23 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-1
  127. - 5.2.1
  128. * Mon Jul 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  129. - compile on mainframe
  130. * Mon Jul 8 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-3
  131. - Rebuild
  132. * Tue May 7 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-2
  133. - Rebuild
  134. * Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-1
  135. - 5.2
  136. * Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.92-1
  137. - 5.1.92. Hopefully identical to 5.2 final
  138. * Mon Apr 22 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.91-1
  139. - 5.1.91. 5.2 expected in a week
  140. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-5
  141. - Update to current
  142. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-4
  143. - Update to current
  144. * Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-3
  145. - Update to current
  146. * Wed Mar 20 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-2
  147. - Update to current
  148. * Wed Mar 13 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-1
  149. - Update to current 5.2 branch
  150. * Thu Jan 24 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.1-1
  151. - 5.1.1
  152. - add URL
  153. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  154. - automated rebuild
  155. * Mon Dec 10 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-2
  156. - Fix some thread+fpu problems
  157. * Mon Nov 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-1
  158. - 5.1
  159. * Mon Nov 19 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.94-0.71
  160. - 5.0.94. Almost there....
  161. * Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-2
  162. - Add patch from jakub@redhat.com to improve handling of DWARF
  163. * Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-1
  164. - 5.0.93
  165. - handle missing info pages in post/pre scripts
  166. * Wed Oct 31 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.92-1
  167. - 5.0.92
  168. * Fri Oct 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.91rh-1
  169. - New snapshot
  170. - Use the 5.0.91 versioning from the snapshot
  171. * Wed Oct 17 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-17
  172. - New snapshot
  173. * Thu Sep 27 2001 Trond Eivind Glomsr <teg@redhat.com>
  174. - New snapshot
  175. * Wed Sep 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-16
  176. - New snapshot
  177. * Mon Aug 13 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-15
  178. - Don't buildrequire compat-glibc (#51690)
  179. * Thu Aug 9 2001 Trond Eivind Glomsr <teg@redhat.com>
  180. - New snapshot, from the stable branch eventually leading to gdb 5.1
  181. * Mon Jul 30 2001 Trond Eivind Glomsr <teg@redhat.com>
  182. - s/Copyright/License/
  183. - Add texinfo to BuildRequires
  184. * Mon Jun 25 2001 Trond Eivind Glomsr <teg@redhat.com>
  185. - New snapshot
  186. * Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
  187. - New snapshot
  188. - Add ncurses-devel to buildprereq
  189. - Remove perl from buildprereq, as gdb changed the way
  190. version strings are generated
  191. * Thu Jun 14 2001 Trond Eivind Glomsr <teg@redhat.com>
  192. - New snapshot
  193. * Wed May 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  194. - New snapshot - this had thread fixes for curing #39070
  195. - New way of specifying version
  196. * Tue May 1 2001 Trond Eivind Glomsr <teg@redhat.com>
  197. - New tarball
  198. - Kevin's patch is now part of gdb
  199. * Mon Apr 9 2001 Trond Eivind Glomsr <teg@redhat.com>
  200. - Add patch from kevinb@redhat.com to fix floating point + thread
  201. problem (#24310)
  202. - remove old workarounds
  203. - new snapshot
  204. * Thu Apr 5 2001 Trond Eivind Glomsr <teg@redhat.com>
  205. - New snapshot
  206. * Sat Mar 17 2001 Bill Nottingham <notting@redhat.com>
  207. - on ia64, there are no old headers :)
  208. * Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  209. - build with old headers, new compiler
  210. * Wed Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
  211. - new snapshot
  212. * Mon Feb 26 2001 Trond Eivind Glomsr <teg@redhat.com>
  213. - new snapshot which should fix some more IA64 problems (#29151)
  214. - remove IA64 patch, it's now integrated
  215. * Wed Feb 21 2001 Trond Eivind Glomsr <teg@redhat.com>
  216. - add IA64 and Alpha patches from Kevin Buettner <kevinb@redhat.com>
  217. - use perl instead of patch for fixing the version string
  218. * Tue Feb 20 2001 Trond Eivind Glomsr <teg@redhat.com>
  219. - don't use kgcc anymore
  220. - mark it as our own version
  221. - new snapshot
  222. * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  223. - Link with ncurses 5.x even though we're using kgcc.
  224. No need to drag in requirements on ncurses4 (Bug #24445)
  225. * Fri Jan 19 2001 Trond Eivind Glomsr <teg@redhat.com>
  226. - new snapshot
  227. * Thu Dec 20 2000 Trond Eivind Glomsr <teg@redhat.com>
  228. - new snapshot
  229. * Mon Dec 04 2000 Trond Eivind Glomsr <teg@redhat.com>
  230. - new snapshot
  231. - new alpha patch - it now compiles everywhere. Finally.
  232. * Fri Dec 01 2000 Trond Eivind Glomsr <teg@redhat.com>
  233. - new snapshot
  234. * Mon Nov 20 2000 Trond Eivind Glomsr <teg@redhat.com>
  235. - new CVS snapshot
  236. - disable the patches
  237. - don't use %%configure, as it confuses the autoconf script
  238. - enable SPARC, disable Alpha
  239. * Wed Aug 09 2000 Trond Eivind Glomsr <teg@redhat.com>
  240. - added patch from GDB team for C++ symbol handling
  241. * Mon Jul 25 2000 Trond Eivind Glomsr <teg@redhat.com>
  242. - upgrade to CVS snapshot
  243. - excludearch SPARC, build on IA61
  244. * Wed Jul 19 2000 Trond Eivind Glomsr <teg@redhat.com>
  245. - rebuild
  246. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  247. - automatic rebuild
  248. * Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
  249. - rebuild
  250. * Fri Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
  251. - use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir},
  252. and %%{_tmppath}
  253. - the install scripts for info are broken(they don't care about
  254. you specify in the installstep), work around that.
  255. - don't build for IA64
  256. * Mon May 22 2000 Trond Eivind Glomsr <teg@redhat.com>
  257. - upgraded to 5.0 - dump all patches. Reapply later if needed.
  258. - added the NEWS file to the %%doc files
  259. - don't delete files which doesn't get installed (readline, texinfo)
  260. - let build system handle stripping and gzipping
  261. - don't delete libmmalloc
  262. - apply patch from jakub@redhat.com to make it build on SPARC
  263. * Fri Apr 28 2000 Matt Wilson <msw@redhat.com>
  264. - rebuilt against new ncurses
  265. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  266. - rebuild for sparc baud rates > 38400.
  267. * Tue Feb 8 2000 Jakub Jelinek <jakub@redhat.com>
  268. - fix core file handling on i386 with glibc 2.1.3 headers
  269. * Fri Jan 14 2000 Jakub Jelinek <jakub@redhat.com>
  270. - fix reading registers from core on sparc.
  271. - hack around build problems on i386 with glibc 2.1.3 headers
  272. * Thu Oct 7 1999 Jim Kingdon
  273. - List files to install in /usr/info specifically (so we don't pick up
  274. things like info.info from GDB snapshots).
  275. * Thu Oct 7 1999 Jim Kingdon
  276. - Update GDB to 19991004 snapshot. This eliminates the need for the
  277. sigtramp, sparc, xref, and threads patches. Update sparcmin patch.
  278. * Mon Aug 23 1999 Jim Kingdon
  279. - Omit readline manpage.
  280. * Tue Aug 7 1999 Jim Kingdon
  281. - Remove H.J. Lu's patches (they had been commented out).
  282. - Add sigtramp patch (from gdb.cygnus.com) and threads patch (adapted
  283. from code fusion CD-ROM).
  284. * Wed Apr 14 1999 Jeff Johnson <jbj@redhat.com>
  285. - merge H.J. Lu's patches into 4.18.
  286. * Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
  287. - updated the kern22 patch with stuff from davem
  288. * Thu Apr 1 1999 Jeff Johnson <jbj@redhat.com>
  289. - sparc with 2.2 kernels no longer uses sunos ptrace (davem)
  290. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  291. - auto rebuild in the new build environment (release 3)
  292. * Mon Mar 8 1999 Jeff Johnson <jbj@redhat.com>
  293. - Sparc fiddles for Red Hat 6.0.