webkitgtk4-vl.spec 9.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331
  1. %bcond_with clang
  2. ## NOTE: Lots of files in various subdirectories have the same name (such as
  3. ## "LICENSE") so this short macro allows us to distinguish them by using their
  4. ## directory names (from the source tree) as prefixes for the files.
  5. %global add_to_license_files() \
  6. mkdir -p _license_files ; \
  7. cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
  8. Name: webkitgtk4
  9. Version: 2.26.0
  10. Release: 1%{?_dist_release}
  11. Summary: GTK+ Web content engine library
  12. License: LGPLv2
  13. Group: System Environment/Libraries
  14. URL: http://www.webkitgtk.org/
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. Source0: https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
  18. Patch3: webkitgtk-2.5.2-commit_align.patch
  19. %if %{with clang}
  20. BuildRequires: clang
  21. BuildRequires: lld
  22. %endif
  23. BuildRequires: at-spi2-core-devel
  24. BuildRequires: bison
  25. BuildRequires: bubblewrap
  26. BuildRequires: cairo-devel
  27. BuildRequires: cmake
  28. BuildRequires: enchant-devel
  29. BuildRequires: flex
  30. BuildRequires: fontconfig-devel
  31. BuildRequires: freetype-devel
  32. BuildRequires: geoclue2-devel
  33. BuildRequires: gettext
  34. BuildRequires: glib2-devel
  35. BuildRequires: gobject-introspection-devel
  36. BuildRequires: gperf
  37. BuildRequires: gstreamer1-devel
  38. BuildRequires: gstreamer1-plugins-base-devel
  39. BuildRequires: gtk2-devel
  40. BuildRequires: gtk3-devel
  41. BuildRequires: harfbuzz-icu-devel
  42. BuildRequires: libicu-devel
  43. BuildRequires: libjpeg-turbo-devel
  44. BuildRequires: libpng-devel
  45. BuildRequires: libseccomp-devel
  46. BuildRequires: libsecret-devel
  47. BuildRequires: libsoup-devel
  48. BuildRequires: libwebp-devel
  49. BuildRequires: libxslt-devel
  50. BuildRequires: libXt-devel
  51. BuildRequires: ninja
  52. BuildRequires: mesa-libGL-devel
  53. BuildRequires: pcre-devel
  54. BuildRequires: python3-devel
  55. BuildRequires: ruby
  56. BuildRequires: sqlite3-devel
  57. BuildRequires: libnotify-devel
  58. BuildRequires: hyphen-devel
  59. BuildRequires: woff2-devel
  60. BuildRequires: xdg-dbus-proxy
  61. #Requires: geoclue2
  62. # for sandbox
  63. Requires: bubblewrap
  64. Requires: xdg-dbus-proxy
  65. # Require the jsc subpackage
  66. Requires: %{name}-jsc = %{version}-%{release}
  67. # Obsolete libwebkit2gtk from the webkitgtk3 package
  68. Obsoletes: libwebkit2gtk < 2.4.5-3
  69. Provides: libwebkit2gtk = %{version}-%{release}
  70. # Filter out provides for private libraries
  71. %global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
  72. %description
  73. WebKitGTK+ is the port of the portable web rendering engine WebKit to the
  74. GTK+ platform.
  75. This package contains WebKitGTK+ for GTK+ 3.
  76. %package devel
  77. Summary: Development files for %{name}
  78. Group: Development/Libraries
  79. Requires: %{name} = %{version}-%{release}
  80. Requires: %{name}-jsc-devel = %{version}-%{release}
  81. %description devel
  82. The %{name}-devel package contains libraries, build data, and header
  83. files for developing applications that use %{name}.
  84. %package jsc
  85. Summary: JavaScript engine from %{name}
  86. Group: System Environment/Libraries
  87. %description jsc
  88. This package contains JavaScript engine from %{name}.
  89. %package jsc-devel
  90. Summary: Development files for JavaScript engine from %{name}
  91. Group: Development/Libraries
  92. Requires: %{name}-jsc = %{version}-%{release}
  93. %description jsc-devel
  94. The %{name}-jsc-devel package contains libraries, build data, and header
  95. files for developing applications that use JavaScript engine from %{name}.
  96. %prep
  97. %setup -q -n webkitgtk-%{version}
  98. %ifarch %{power64} aarch64 ppc
  99. %patch3 -p1 -b .commit_align
  100. %endif
  101. # Remove bundled libraries
  102. rm -rf Source/ThirdParty/leveldb/
  103. rm -rf Source/ThirdParty/gtest/
  104. rm -rf Source/ThirdParty/qunit/
  105. %build
  106. # binutils-2.23 doesn't support "reduce-memory-overheads"
  107. # Use linker flags to reduce memory consumption
  108. # global optflags %{optflags} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads
  109. %if %{with clang}
  110. %ifnarch x86_64
  111. %define cflags_add --rtlib=compiler-rt
  112. %endif
  113. %global optflags %(echo %{optflags} -DENABLE_YARR_JIT=0 | sed -e 's/-fno-schedule-insns2//') -fuse-ld=lld %{?cflags_add}
  114. %else
  115. %global optflags %{optflags} -DENABLE_YARR_JIT=0
  116. %endif
  117. mkdir -p %{_target_platform}
  118. pushd %{_target_platform}
  119. %if %{with clang}
  120. export CC=clang
  121. export CXX=clang++
  122. export LD=ld.lld
  123. %endif
  124. %cmake \
  125. -GNinja \
  126. %if %{with clang}
  127. -DCOMPILER_IS_CLANG=ON \
  128. -DCMAKE_CXX_COMPILER=clang++ \
  129. %endif
  130. -DPORT=GTK \
  131. -DCMAKE_BUILD_TYPE=Release \
  132. -DENABLE_JIT=OFF \
  133. -DENABLE_LLINT_C_LOOP=ON \
  134. -DUSE_GSTREAMER_GL=OFF \
  135. -DUSE_OPENJPEG=OFF \
  136. -DENABLE_GTKDOC=OFF \
  137. ..
  138. popd
  139. ninja -C %{_target_platform}
  140. %install
  141. DESTDIR=%{buildroot} ninja -C %{_target_platform} install
  142. %find_lang WebKit2GTK-4.0
  143. # Finally, copy over and rename various files for %%license inclusion
  144. %add_to_license_files Source/JavaScriptCore/COPYING.LIB
  145. %add_to_license_files Source/JavaScriptCore/icu/LICENSE
  146. %add_to_license_files Source/ThirdParty/ANGLE/LICENSE
  147. %add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
  148. %add_to_license_files Source/WebCore/icu/LICENSE
  149. %add_to_license_files Source/WebCore/LICENSE-APPLE
  150. %add_to_license_files Source/WebCore/LICENSE-LGPL-2
  151. %add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
  152. %add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
  153. %add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
  154. %add_to_license_files Source/WTF/icu/LICENSE
  155. %add_to_license_files Source/WTF/wtf/dtoa/COPYING
  156. %add_to_license_files Source/WTF/wtf/dtoa/LICENSE
  157. %post -p /sbin/ldconfig
  158. %postun -p /sbin/ldconfig
  159. %post jsc -p /sbin/ldconfig
  160. %postun jsc -p /sbin/ldconfig
  161. %files -f WebKit2GTK-4.0.lang
  162. %license _license_files/*
  163. %{_libdir}/libwebkit2gtk-4.0.so.*
  164. %{_libdir}/girepository-1.0/WebKit2-4.0.typelib
  165. %{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
  166. %{_libdir}/webkit2gtk-4.0/
  167. %{_libexecdir}/webkit2gtk-4.0/*
  168. %exclude %{_libexecdir}/webkit2gtk-4.0/jsc
  169. %{_bindir}/WebKitWebDriver
  170. %files jsc
  171. %license _license_files/*JavaScriptCore*
  172. %dir %{_libexecdir}/webkit2gtk-4.0/
  173. %{_libexecdir}/webkit2gtk-4.0/jsc
  174. %{_libdir}/libjavascriptcoregtk-4.0.so.*
  175. %{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
  176. %files devel
  177. %{_includedir}/webkitgtk-4.0/*
  178. %exclude %{_includedir}/webkitgtk-4.0/JavaScriptCore/
  179. %{_libdir}/libwebkit2gtk-4.0.so
  180. %{_libdir}/pkgconfig/webkit2gtk-4.0.pc
  181. %{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
  182. %{_datadir}/gir-1.0/WebKit2-4.0.gir
  183. %{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
  184. %files jsc-devel
  185. %dir %{_includedir}/webkitgtk-4.0
  186. %{_includedir}/webkitgtk-4.0/JavaScriptCore/
  187. %{_libdir}/libjavascriptcoregtk-4.0.so
  188. %{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
  189. %{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
  190. %changelog
  191. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.0-1
  192. - new upstream release.
  193. - switched build-system to ninja.
  194. * Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.24.3-1
  195. - new upstream release.
  196. * Thu Jan 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.22.5-1
  197. - new upstream release.
  198. * Thu Jan 11 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.5-1
  199. - new upstream release.
  200. - added subpackages webkitgtk4-jsc{,-devel}.
  201. * Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.4-1
  202. - new upstream release.
  203. * Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.12.3-2
  204. - rebuilt with new toolchain.
  205. * Sun Jun 12 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.3-1
  206. - new upstream release
  207. (including security fix for CVE-2016-1856,1857)
  208. * Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.2-1
  209. - new upstream release
  210. - remove Patch0
  211. - add BuildRequires: libnotify-devel, hyphen-devel
  212. * Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-3
  213. - rebuild with gnutls-3.4.7
  214. * Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-2
  215. - rebuild with icu-56.1
  216. * Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-1
  217. - new upstream release
  218. * Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.4-1
  219. - new upstream release
  220. * Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.3-1
  221. - new upstream release
  222. * Fri May 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-1
  223. - new upstream release
  224. * Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-1
  225. - new upstream release
  226. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
  227. - new upstream release
  228. - update Patch0
  229. * Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
  230. - new upstream release
  231. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-2
  232. - add Group tag
  233. * Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-1
  234. - new upstream release
  235. * Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
  236. - new upstream release
  237. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
  238. - initial build for Vine Linux
  239. * Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
  240. - Add the wrongly removed CLoop patch and remove the one that was upstreamed
  241. * Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
  242. - Update to 2.6.0
  243. * Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
  244. - Update to 2.5.90
  245. * Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
  246. - Obsolete libwebkit2gtk from the webkitgtk3 package
  247. * Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
  248. - rebuild for ICU 53.1
  249. * Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
  250. - Add support for secondary arches
  251. * Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
  252. - Add webkitgtk-2.5.3-toggle-buttons.patch
  253. * Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
  254. - More package review fixes (#1131284)
  255. - Correct the license tag to read LGPLv2
  256. - Filter out provides for private libraries
  257. * Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
  258. - Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
  259. * Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
  260. - Update to 2.5.3
  261. * Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
  262. - Initial Fedora packaging, based on the webkitgtk3 package