openssl-vl.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define soversion 10
  3. %define version 1.0.1o
  4. %define release 1%{_dist_release}
  5. Summary: Secure Sockets Layer Toolkit
  6. Name: openssl
  7. Version: %{version}
  8. Release: %{release}
  9. Source: openssl-%{version}.tar.gz
  10. Source2: Makefile.certificate
  11. Source6: make-dummy-cert
  12. Source7: renew-dummy-cert
  13. Patch0: openssl-1.0.0-soversion.patch
  14. Patch2: openssl-1.0.1-rpm_opt.patch
  15. Patch4: openssl-1.0.0-enginesdir.patch
  16. Patch5: openssl-1.0.1m-version-add-engines.patch
  17. Patch8: openssl-1.0.1c-perlfind.patch
  18. # security fix
  19. # nothing ;-)
  20. License: BSDish
  21. Group: System Environment/Libraries
  22. URL: http://www.openssl.org/
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. BuildRequires: perl, sed
  25. BuildRequires: zlib-devel, krb5-devel
  26. Requires: mktemp
  27. Requires: ca-certificates
  28. Vendor: Project Vine
  29. Distribution: Vine Linux
  30. Packager: daisuke, iwamoto
  31. %define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
  32. %description
  33. The OpenSSL certificate management tool and the shared libraries that
  34. provide various cryptographic algorithms and protocols.
  35. %package devel
  36. Summary: OpenSSL libraries and development headers.
  37. Group: Development/Libraries
  38. Requires: %{name} = %{version}-%{release}
  39. Requires: krb5-devel
  40. %description devel
  41. The static libraries and include files needed to compile apps
  42. with support for various the cryptographic algorithms and protocols
  43. supported by OpenSSL.
  44. Patches for many networking apps can be found at:
  45. ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
  46. %package static
  47. Summary: Libraries for static linking of applications which will use OpenSSL
  48. Group: Development/Libraries
  49. Requires: %{name}-devel = %{version}-%{release}
  50. %description static
  51. OpenSSL is a toolkit for supporting cryptography. The openssl-static
  52. package contains static libraries needed for static linking of
  53. applications which support various cryptographic algorithms and
  54. protocols.
  55. %package perl
  56. Summary: OpenSSL scripts which require Perl.
  57. Group: Applications/Internet
  58. Requires: perl
  59. Requires: %{name} = %{version}-%{release}
  60. %description perl
  61. Perl scripts provided with OpenSSL for converting certificates and keys
  62. from other formats to those used by OpenSSL.
  63. ## to build compat32 for x86_64 architecture support
  64. %package -n compat32-%{name}
  65. Summary: Secure Sockets Layer Toolkit
  66. Group: System Environment/Libraries
  67. Requires: %{name} = %{version}-%{release}
  68. %description -n compat32-%{name}
  69. The OpenSSL certificate management tool and the shared libraries that
  70. provide various cryptographic algorithms and protocols.
  71. %package -n compat32-%{name}-devel
  72. Summary: OpenSSL libraries and development headers.
  73. Group: Development/Libraries
  74. Requires: compat32-%{name} = %{version}-%{release}
  75. Requires: compat32-krb5-devel
  76. %description -n compat32-%{name}-devel
  77. The static libraries and include files needed to compile apps
  78. with support for various the cryptographic algorithms and protocols
  79. supported by OpenSSL.
  80. %prep
  81. %setup -q -n openssl-%{version}
  82. %patch0 -p1 -b .soversion
  83. %patch2 -p1 -b .rpm_opt
  84. %patch4 -p1 -b .enginesdir
  85. %patch5 -p1 -b .version-add-engines
  86. %patch8 -p1 -b .perlfind
  87. # security fix
  88. # nothing ;-)
  89. chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
  90. chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
  91. chmod 644 doc/openssl_button.html doc/openssl_button.gif
  92. chmod 644 doc/ssleay.txt
  93. # Link the configuration header to the one we're going to make.
  94. ln -sf ../../crypto/opensslconf.h include/openssl/
  95. %build
  96. PATH=${PATH}:${PWD}/bin
  97. TOPDIR=${PWD}
  98. LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
  99. # Modify the various perl scripts to reference perl in the right location.
  100. perl util/perlpath.pl `dirname %{__perl}`
  101. # Generate a table with the compile settings for my perusal.
  102. touch Makefile
  103. make TABLE PERL=%{__perl}
  104. # Figure out which flags we want to use.
  105. # default
  106. sslarch=%{_os}-%{_target_cpu}
  107. #
  108. %ifarch %ix86
  109. sslarch=linux-elf
  110. if ! echo %{_target} | grep -q i686 ; then
  111. sslflags="no-asm 386"
  112. fi
  113. %endif
  114. %ifarch sparcv9
  115. sslarch=linux-sparcv9
  116. sslflags=no-asm
  117. %endif
  118. %ifarch sparc64
  119. sslarch=linux64-sparcv9
  120. sslflags=no-asm
  121. %endif
  122. %ifarch alpha alphaev56 alphaev6 alphaev67
  123. sslarch=linux-alpha-gcc
  124. %endif
  125. %ifarch s390 sh3eb sh4eb
  126. sslarch="linux-generic32 -DB_ENDIAN"
  127. %endif
  128. %ifarch s390x
  129. sslarch="linux64-s390x"
  130. %endif
  131. %ifarch %{arm} sh3 sh4
  132. sslarch=linux-generic32
  133. %endif
  134. # ia64/x86_64/ppc\ppc64 are OK by default.
  135. # Configure the build tree. Override OpenSSL defaults with known-good defaults
  136. # usable on all platforms. The Configure script already knows to use -fPIC and
  137. # RPM_OPT_FLAGS, so we can skip specifiying them here.
  138. ./Configure \
  139. --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
  140. zlib-dynamic enable-camellia enable-seed enable-tlsext \
  141. enable-rfc3779 enable-cms enable-md2 \
  142. --enginesdir=%{_libdir}/openssl/engines \
  143. --with-krb5-flavor=MIT --with-krb5-dir=/usr \
  144. shared ${sslarch}
  145. # Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
  146. # marked as not requiring an executable stack.
  147. RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
  148. make depend
  149. make all build-shared
  150. # Generate hashes for the included certs.
  151. LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
  152. export LD_LIBRARY_PATH
  153. make rehash build-shared
  154. # Verify that what was compiled actually works.
  155. make -C test apps tests
  156. # Relink the main binary to get it dynamically linked.
  157. rm apps/openssl
  158. make all build-shared
  159. %install
  160. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  161. # Install OpenSSL.
  162. install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
  163. make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
  164. install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
  165. # added for lib64
  166. # mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
  167. mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/openssl
  168. # mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
  169. mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
  170. mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man/* $RPM_BUILD_ROOT%{_mandir}
  171. rmdir $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man
  172. rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
  173. for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
  174. chmod 755 ${lib}
  175. ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
  176. ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
  177. done
  178. # install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
  179. # Install a makefile for generating keys and self-signed certs, and a script
  180. # for generating them on the fly.
  181. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
  182. install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/Makefile
  183. install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/make-dummy-cert
  184. install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
  185. # Make sure we actually include the headers we built against.
  186. for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
  187. if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
  188. install -m644 include/openssl/`basename ${header}` ${header}
  189. fi
  190. done
  191. # Rename man pages so that they don't conflict with system man pages. We used
  192. # to change the file extensions, but that only prevents file conflicts. The
  193. # man viewer still can't select either of the two unless we physically change
  194. # the directory.
  195. for section in 1 2 3 4 5 6 7 8 ; do
  196. if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
  197. mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
  198. $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
  199. fi
  200. done
  201. # Pick a CA script.
  202. pushd $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc
  203. mv CA.sh CA
  204. popd
  205. mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
  206. mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
  207. mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
  208. mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
  209. mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
  210. # Ensure the openssl.cnf timestamp is identical across builds to avoid
  211. # mulitlib conflicts and unnecessary renames on upgrade
  212. touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
  213. %clean
  214. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  215. %files
  216. %defattr(-,root,root)
  217. %doc FAQ LICENSE CHANGES NEWS INSTALL README
  218. %doc doc/README doc/c-indentation.el doc/openssl.txt
  219. %doc doc/openssl_button.html doc/openssl_button.gif
  220. %doc doc/ssleay.txt
  221. %{_sysconfdir}/pki/tls/certs/make-dummy-cert
  222. %{_sysconfdir}/pki/tls/certs/renew-dummy-cert
  223. %{_sysconfdir}/pki/tls/certs/Makefile
  224. %{_sysconfdir}/pki/tls/misc/CA
  225. %dir %{_sysconfdir}/pki/CA
  226. %dir %{_sysconfdir}/pki/CA/private
  227. %dir %{_sysconfdir}/pki/CA/certs
  228. %dir %{_sysconfdir}/pki/CA/crl
  229. %dir %{_sysconfdir}/pki/CA/newcerts
  230. %{_sysconfdir}/pki/tls/misc/c_*
  231. %dir %{_sysconfdir}/pki/tls
  232. %dir %{_sysconfdir}/pki/tls/certs
  233. %dir %{_sysconfdir}/pki/tls/misc
  234. %dir %{_sysconfdir}/pki/tls/private
  235. %config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
  236. %attr(0755,root,root) %{_bindir}/openssl
  237. %attr(0755,root,root) /%{_lib}/*.so.*
  238. %attr(0755,root,root) %{_libdir}/openssl/engines/*.so
  239. %attr(0755,root,root) %dir %{_mandir}/man1*
  240. %attr(0644,root,root) %{_mandir}/man1*/*
  241. %attr(0755,root,root) %dir %{_mandir}/man5*
  242. %attr(0644,root,root) %{_mandir}/man5*/*
  243. %attr(0755,root,root) %dir %{_mandir}/man7*
  244. %attr(0644,root,root) %{_mandir}/man7*/*
  245. %files devel
  246. %defattr(-,root,root)
  247. %{_prefix}/include/openssl
  248. %exclude %{_libdir}/lib*.a
  249. %attr(0755,root,root) %{_libdir}/*.so
  250. %attr(0755,root,root) %dir %{_mandir}/man3*
  251. %attr(0644,root,root) %{_mandir}/man3*/*
  252. %attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
  253. %files static
  254. %defattr(-,root,root)
  255. %attr(0644,root,root) %{_libdir}/*.a
  256. %files perl
  257. %defattr(-,root,root)
  258. %attr(0755,root,root) %{_bindir}/c_rehash
  259. %attr(0755,root,root) %dir %{_mandir}/man1*
  260. %attr(0644,root,root) %{_mandir}/man1*/*.pl*
  261. %{_sysconfdir}/pki/tls/misc/*.pl
  262. #%{_sysconfdir}/pki/tls/misc/tsget
  263. %doc apps/tsget
  264. ## to build compat32 for x86_64 architecture support
  265. %if %{build_compat32}
  266. %files -n compat32-%{name}
  267. %defattr(-,root,root)
  268. %attr(0755,root,root) /%{_lib}/*.so.*
  269. %files -n compat32-%{name}-devel
  270. %defattr(-,root,root)
  271. %exclude %{_libdir}/lib*.a
  272. %attr(0755,root,root) %{_libdir}/*.so
  273. %attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
  274. %endif
  275. %post -p /sbin/ldconfig
  276. %postun -p /sbin/ldconfig
  277. %post -n compat32-%{name} -p /sbin/ldconfig
  278. %postun -n compat32-%{name} -p /sbin/ldconfig
  279. %changelog
  280. * Wed Jul 1 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1o-1
  281. - new upstream release
  282. * Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1m-1
  283. - merged into Vine6
  284. * Fri Mar 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1m-1
  285. - new upstream release with security fixes
  286. - update Patch2,5
  287. * Mon Jan 12 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1k-1
  288. - new upstream release with security fixes
  289. * Mon Oct 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1j-1
  290. - new upstream release with security fixes
  291. - add patch8 from fc21 (fix perl find.pl)
  292. * Fri Jun 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1h-1
  293. - new upstream release with security fixes.
  294. * Tue Apr 8 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1g-1
  295. - new upstream release with security fixes
  296. * Thu Jan 9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1f-1
  297. - new upstream release with security fixes
  298. * Tue Sep 24 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-2
  299. - move root CA bundle to ca-certificates package
  300. * Tue Feb 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-1
  301. - update to 1.0.1e
  302. - 1.0.1d has major regressions from 1.0.1c
  303. * Sat Feb 9 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.1d-2
  304. - remove tsget script to delete dependency perl(WWW::Curl::Easy)
  305. - openssl-perl package contains it in docdir
  306. * Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1d-1
  307. - new upstream release with security fix (CVE-2012-2686, CVE-2013-0166, 0169)
  308. - fixed %%files
  309. * Tue May 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1c-1
  310. - update to 1.0.1c
  311. - enable configure options:
  312. enable-camellia enable-seed enable-tlsext enable-rfc3779
  313. enable-cms enable-md2
  314. - remove no-asm option from ai64/x86_64/ppc/ppc64/i686
  315. - generate a table with the compile settings before configure
  316. * Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
  317. - new upstream release with security fix (CVE-2012-0050)
  318. * Fri Jan 6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
  319. - new upstream release with security fix
  320. (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
  321. * Wed Sep 7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
  322. - new upstream release with security fix (CVE-2011-3207, 3210)
  323. * Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
  324. - rebuild with krb5-libs 1.8
  325. * Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
  326. - new upstream release with security fix
  327. * Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
  328. - use upstream openssl.pc instead of vine original one (SOURCE6)
  329. * Sun Jan 9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
  330. - move tsget to docs to delete dependency perl(WWW::Curl::Easy)
  331. * Sat Jan 1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
  332. - add R: krb5-devel into devel pkg
  333. - add R: compat32-krb5-devel into compat32-devel pkg
  334. * Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
  335. - new upstream release 1.0.0x
  336. - separate static libs into static package
  337. - change configure options
  338. - change so version 10
  339. - add tsget into perl package
  340. - update all patches
  341. * Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
  342. - fix changelog typo...
  343. * Tue Dec 7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
  344. - new upstream release with security fix (CVE-2010-4180)
  345. * Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
  346. - new upstream release with security fix (CVE-2010-3864)
  347. - drop patches included in new release
  348. - update patch4
  349. * Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
  350. - add patch12 for fix CVE-2009-3555 (renegotiation)
  351. * Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
  352. - add patch11 for fix CVE-2009-4355 (memory leak)
  353. * Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
  354. - add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
  355. * Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
  356. - removed unnecessary %%if %{build_compat32} statements
  357. - removed lib*.a from devel package
  358. * Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
  359. - new upstream release with security fix (CVE-2000-0590,0591,0789)
  360. * Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
  361. - new upstream release with security fix (CVE-2008-5077)
  362. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
  363. - new upstream release
  364. * Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
  365. - new upstream release
  366. - new versioning policy
  367. * Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
  368. - new upstream release
  369. - drop patch10,20 which is merged in upstream
  370. * Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
  371. - add security patch in advance for CVE-2007-5135
  372. http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
  373. http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
  374. * Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
  375. - add security patch for CVE-2007-3108
  376. (http://openssl.org/news/patch-CVE-2007-3108.txt)
  377. * Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
  378. - new upstream release
  379. * Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
  380. - update (fix) openssl.pc <BTS:437>
  381. * Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
  382. - new upstream release (with security fix)
  383. * Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
  384. - new upstream release
  385. - add patch2 to use RPM_OPT macro
  386. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
  387. - moved macros _lib to /usr/lib/rpm/rpmrc or macros files
  388. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
  389. - added compat32-* packages for x86_64 architecture support
  390. - added openssl-0.9.7i.Configure-compat32.patch
  391. - changed '/lib' to '/%{_lib}'
  392. * Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
  393. - new upstream release
  394. * Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
  395. - rebuild on VineSeed
  396. * Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
  397. - added a security patch from Gentoo.
  398. - Patch1: openssl-0.9.7c-tempfile.patch
  399. * Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
  400. - sslarch for ppc was missing... added.
  401. * Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
  402. - use sslarch=linux-alpha-gcc instead of alpha-gcc
  403. * Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
  404. - new upstream version
  405. - clean up of spec file
  406. -- removed old patches
  407. * Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
  408. - new upstream release
  409. - SECURITY fix.
  410. - http://www.openssl.org/news/secadv_20040317.txt
  411. * Wed Oct 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
  412. - new upstream release
  413. - [Security fix]
  414. - Vulnerabilities in ASN.1 parsing
  415. http://www.openssl.org/news/secadv_20030930.txt
  416. - see %{_docdir}/%{name}-%{version}/CHANGES for other changes
  417. * Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
  418. - add openssl.pc for pkgconfig
  419. * Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
  420. - New upstream version
  421. - dropped patch10, 11
  422. -- merged upstream version
  423. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
  424. - rebuild for VineSeed
  425. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
  426. - [Security Fix]
  427. - Timing-based attacks on RSA keys
  428. http://www.openssl.org/news/secadv_20030317.txt
  429. - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
  430. http://www.openssl.org/news/secadv_20030317.txt
  431. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
  432. - new upstream release 0.9.6i
  433. - [Security Fix]
  434. - build for Vine Linux 2.6 errata
  435. * Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
  436. - new upstream release 0.9.6h
  437. * Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
  438. - new upstream release 0.9.6g
  439. * Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
  440. - SECURITY: CAN-2002-0659 fixed
  441. - added Patch101 from RedHat 7.2 updates 0.9.6b-28
  442. * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
  443. - update asn patch to fix accidental reversal of a logic check
  444. * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
  445. - update asn patch to reduce chance that compiler optimization will remove
  446. one of the added tests
  447. * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
  448. - rebuild
  449. * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
  450. - add patch to fix ASN.1 vulnerabilities
  451. * Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
  452. - rename spec file name
  453. - SECURITY: CA-2002-23 fixed
  454. - added Patch100 from RedHat 7.2 updates 0.9.6b-24
  455. * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
  456. - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
  457. * Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
  458. - added ${PATH} in LD_LIBRARY_PATH
  459. - added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
  460. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
  461. - remove --no-<cipher>
  462. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
  463. - add Patch10 for mipsel shared ( Configure )
  464. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
  465. - build for Vine Linux
  466. - use openssl-engine-0.9.6b.tar.gz
  467. * Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
  468. - update to 0.9.6b
  469. * Thu Jul 5 2001 Nalin Dahyabhai <nalin@redhat.com>
  470. - move .so symlinks back to %%{_libdir}
  471. * Tue Jul 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  472. - move shared libraries to /lib (#38410)
  473. * Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
  474. - switch to engine code base
  475. * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
  476. - add a script for creating dummy certificates
  477. - move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
  478. * Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  479. - add s390x support
  480. * Fri Jun 1 2001 Nalin Dahyabhai <nalin@redhat.com>
  481. - change two memcpy() calls to memmove()
  482. - don't define L_ENDIAN on alpha
  483. * Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
  484. - make subpackages depend on the main package
  485. * Tue May 1 2001 Nalin Dahyabhai <nalin@redhat.com>
  486. - adjust the hobble script to not disturb symlinks in include/ (fix from
  487. Joe Orton)
  488. * Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  489. - drop the m2crypo patch we weren't using
  490. * Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
  491. - configure using "shared" as well
  492. * Sun Apr 8 2001 Nalin Dahyabhai <nalin@redhat.com>
  493. - update to 0.9.6a
  494. - use the build-shared target to build shared libraries
  495. - bump the soversion to 2 because we're no longer compatible with
  496. our 0.9.5a packages or our 0.9.6 packages
  497. - drop the patch for making rsatest a no-op when rsa null support is used
  498. - put all man pages into <section>ssl instead of <section>
  499. - break the m2crypto modules into a separate package
  500. * Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
  501. - use BN_LLONG on s390
  502. * Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
  503. - fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
  504. * Sat Mar 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  505. - move c_rehash to the perl subpackage, because it's a perl script now
  506. * Fri Mar 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  507. - update to 0.9.6
  508. - enable MD2
  509. - use the libcrypto.so and libssl.so targets to build shared libs with
  510. - bump the soversion to 1 because we're no longer compatible with any of
  511. the various 0.9.5a packages circulating around, which provide lib*.so.0
  512. * Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  513. - change hobble-openssl for disabling MD2 again
  514. * Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  515. - re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
  516. bytes or so, causing EVP_DigestInit() to zero out stack variables in
  517. apps built against a version of the library without it
  518. * Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  519. - disable some inline assembly, which on x86 is Pentium-specific
  520. - re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
  521. * Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  522. - fix s390 patch
  523. * Fri Dec 8 2000 Than Ngo <than@redhat.com>
  524. - added support s390
  525. * Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  526. - remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
  527. - add the CA.pl man page to the perl subpackage
  528. * Thu Nov 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  529. - always build with -mcpu=ev5 on alpha
  530. * Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
  531. - add a symlink from cert.pem to ca-bundle.crt
  532. * Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
  533. - add a ca-bundle file for packages like Samba to reference for CA certificates
  534. * Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
  535. - remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
  536. * Mon Oct 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  537. - add unzip as a buildprereq (#17662)
  538. - update m2crypto to 0.05-snap4
  539. * Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
  540. - fix some issues in building when it's not installed
  541. * Wed Sep 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  542. - make sure the headers we include are the ones we built with (aaaaarrgh!)
  543. * Fri Sep 1 2000 Nalin Dahyabhai <nalin@redhat.com>
  544. - add Richard Henderson's patch for BN on ia64
  545. - clean up the changelog
  546. * Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  547. - fix the building of python modules without openssl-devel already installed
  548. * Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
  549. - byte-compile python extensions without the build-root
  550. - adjust the makefile to not remove temporary files (like .key files when
  551. building .csr files) by marking them as .PRECIOUS
  552. * Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  553. - break out python extensions into a subpackage
  554. * Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  555. - tweak the makefile some more
  556. * Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
  557. - disable MD2 support
  558. * Thu Jul 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  559. - disable MDC2 support
  560. * Sun Jul 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  561. - tweak the disabling of RC5, IDEA support
  562. - tweak the makefile
  563. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  564. - strip binaries and libraries
  565. - rework certificate makefile to have the right parts for Apache
  566. * Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  567. - use %%{_perl} instead of /usr/bin/perl
  568. - disable alpha until it passes its own test suite
  569. * Fri Jun 9 2000 Nalin Dahyabhai <nalin@redhat.com>
  570. - move the passwd.1 man page out of the passwd package's way
  571. * Fri Jun 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  572. - update to 0.9.5a, modified for U.S.
  573. - add perl as a build-time requirement
  574. - move certificate makefile to another package
  575. - disable RC5, IDEA, RSA support
  576. - remove optimizations for now
  577. * Wed Mar 1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  578. - Bero told me to move the Makefile into this package
  579. * Wed Mar 1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  580. - add lib*.so symlinks to link dynamically against shared libs
  581. * Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  582. - update to 0.9.5
  583. - run ldconfig directly in post/postun
  584. - add FAQ
  585. * Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  586. - Fix build on non-x86 platforms
  587. * Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  588. - move /usr/share/ssl/* from -devel to main package
  589. * Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  590. - inital packaging
  591. - changes from base:
  592. - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
  593. - handle RPM_OPT_FLAGS