git-vl.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865866867868869870871872873874875876877878879880881
  1. %bcond_with arch
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define emacsen_pkgdir /usr/lib/emacsen-common/packages
  4. # Pass --without docs to rpmbuild if you don't want the documentation
  5. Name: git
  6. Version: 2.11.1
  7. Release: 1%{?_dist_release}
  8. Summary: Core git tools
  9. Summary(ja): Core git ツール
  10. License: GPLv2
  11. Group: Development/Tools
  12. URL: http://git-scm.com/
  13. Source0: https://www.kernel.org/pub/software/scm/git/%{name}-%{version}.tar.xz
  14. Source1: vine-default-git.el
  15. Source2: git.xinetd
  16. Source3: git.conf.httpd
  17. Source4: gitweb.conf.in
  18. Source10: %{name}-install.sh
  19. Source11: %{name}-remove.sh
  20. Source12: git-init.el
  21. Patch0: git-1.5-gitweb-home-link.patch
  22. # Security
  23. # none
  24. BuildRequires: zlib-devel >= 1.2, openssl-devel, curl-devel
  25. BuildRequires: expat-devel, gettext, asciidoc
  26. BuildRequires: pcre-devel
  27. BuildRequires: xmlto
  28. # git-credential-gnome-keyring
  29. BuildRequires: glib2-devel libgnome-keyring-devel
  30. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  31. Requires: perl-Git = %{version}-%{release}
  32. Requires: zlib
  33. Provides: git-core = %{version}-%{release}
  34. Obsoletes: git-core <= 1.5.4.3
  35. Vendor: Project Vine
  36. Distribution: Vine Linux
  37. Packager: iwaim
  38. %description
  39. Git is a fast, scalable, distributed revision control system with an
  40. unusually rich command set that provides both high-level operations
  41. and full access to internals.
  42. The git rpm installs the core tools with minimal dependencies. To
  43. install all git packages, including tools for integrating with other
  44. SCMs, install the git-all meta-package.
  45. %package all
  46. Summary: Meta-package to pull in all git tools
  47. Summary(ja): すべての git ツール
  48. Group: Development/Tools
  49. Requires: git = %{version}-%{release}
  50. Requires: git-svn = %{version}-%{release}
  51. Requires: git-cvs = %{version}-%{release}
  52. %if "%{?_dist_release}" != "vl4" && %{with arch}
  53. Requires: git-arch = %{version}-%{release}
  54. %endif
  55. Requires: git-email = %{version}-%{release}
  56. Requires: gitk = %{version}-%{release}
  57. Requires: git-gui = %{version}-%{release}
  58. Requires: perl-Git = %{version}-%{release}
  59. Requires: emacs-git = %{version}-%{release}
  60. Requires: git-contrib = %{version}-%{release}
  61. Obsoletes: git <= 1.5.4.3
  62. %description all
  63. Git is a fast, scalable, distributed revision control system with an
  64. unusually rich command set that provides both high-level operations
  65. and full access to internals.
  66. This is a dummy package which brings in all subpackages.
  67. %package daemon
  68. Summary: Git protocol daemon
  69. Summary(ja): Git プロトコルデーモン
  70. Group: Development/Tools
  71. Requires: git = %{version}-%{release}
  72. %description daemon
  73. The git daemon for supporting git:// access to git repositories
  74. %package -n gitweb
  75. Summary: Simple web interface to git repositories
  76. Summary(ja): git リポジトリへのシンプルな Web インタフェース
  77. Group: Development/Tools
  78. Requires: git = %{version}-%{release}
  79. %description -n gitweb
  80. Simple web interface to track changes in git repositories
  81. %package svn
  82. Summary: Git tools for importing Subversion repositories
  83. Summary(ja): Subversion リポジトリを git へインポートするためのツール
  84. Group: Development/Tools
  85. Requires: git = %{version}-%{release}, subversion, perl(Term::ReadKey)
  86. Requires: perl(SVN::Core)
  87. %description svn
  88. Git tools for importing Subversion repositories.
  89. %package cvs
  90. Summary: Git tools for importing CVS repositories
  91. Summary(ja): CVS リポジトリを git へインポートするためのツール
  92. Group: Development/Tools
  93. Requires: git = %{version}-%{release}, cvs, cvsps
  94. %description cvs
  95. Git tools for importing CVS repositories.
  96. %package contrib
  97. Summary: Git contrib tools
  98. Group: Development/Tools
  99. Requires: git = %{version}-%{release}
  100. %description contrib
  101. Git contrib tools
  102. %if "%{?_dist_release}" != "vl4" && %{with arch}
  103. %package arch
  104. Summary: Git tools for importing Arch repositories
  105. Summary(ja): Arch リポジトリを git へインポートするためのツール
  106. Group: Development/Tools
  107. Requires: git = %{version}-%{release}, tla
  108. %description arch
  109. Git tools for importing Arch repositories.
  110. %endif
  111. %package email
  112. Summary: Git tools for sending email
  113. Summary(ja): Eメールを送るための git ツール
  114. Group: Development/Tools
  115. Requires: git = %{version}-%{release}, perl-Git = %{version}-%{release}
  116. %description email
  117. Git tools for sending email.
  118. %package gui
  119. Summary: Git GUI tool
  120. Summary(ja): Git の GUI ツール
  121. Group: Development/Tools
  122. Requires: git = %{version}-%{release}, tk
  123. %description gui
  124. Git GUI tool.
  125. %package -n gitk
  126. Summary: Git revision tree visualiser
  127. Summary(ja): Git リビジョンツリー可視化ツール
  128. Group: Development/Tools
  129. Requires: git = %{version}-%{release}, tk
  130. %description -n gitk
  131. Git revision tree visualiser.
  132. %package -n perl-Git
  133. Summary: Perl interface to Git
  134. Summary(ja): Git の perl インタフェース
  135. Group: Development/Libraries
  136. Requires: git = %{version}-%{release}, perl(Error)
  137. %if "%{?_dist_release}" == "vl4"
  138. Requires: perl = %(rpm -q --qf '%%{epoch}:%%{version}' perl)
  139. %else
  140. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  141. %endif
  142. #BuildRequires: perl(Error), perl(ExtUtils::MakeMaker)
  143. %description -n perl-Git
  144. Perl interface to Git.
  145. %package -n emacs-git
  146. Summary: Git version control system support for Emacs
  147. Summary(ja): Emacs の Git サポート
  148. Group: Applications/Editors
  149. Requires: git = %{version}-%{release}, emacsen-common
  150. %description -n emacs-git
  151. %{summary}.
  152. %package devel
  153. Summary: Header files for git-core
  154. Summary(ja): git-core 用ヘッダファイル
  155. Group: Development/Libraries
  156. %description devel
  157. Header files for git-core.
  158. %prep
  159. %setup -q
  160. %patch0 -p1
  161. # for pcre-8.12
  162. %if %{?_dist_release} == "vl6"
  163. %{__perl} -pi -e "s|#include <pcre.h>|#include <pcre/pcre.h>|" grep.h
  164. %endif
  165. %__mv contrib/diff-highlight/README contrib/diff-highlight/README.diff-highlight
  166. # Filter bogus perl requires
  167. cat << \EOF > %{name}-req
  168. #!/bin/sh
  169. %{__perl_requires} $* |\
  170. sed -e '/perl(packed-refs)/d'
  171. EOF
  172. %global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
  173. chmod +x %{__perl_requires}
  174. %build
  175. make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS -I%{_includedir/pcre}" \
  176. ETC_GITCONFIG=/etc/gitconfig \
  177. USE_LIBPCRE=1 \
  178. GITWEB_PROJECTROOT=/var/lib/git \
  179. gitwebdir=/var/www/git \
  180. prefix=%{_prefix} all %{!?_without_docs: doc}
  181. %install
  182. rm -rf $RPM_BUILD_ROOT
  183. make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
  184. prefix=%{_prefix} mandir=%{_mandir} \
  185. ETC_GITCONFIG=/etc/gitconfig \
  186. USE_LIBPCRE=1 \
  187. NO_PYTHON=1 \
  188. GITWEB_PROJECTROOT=/var/lib/git \
  189. gitwebdir=/var/www/git \
  190. INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
  191. pushd contrib/credential/gnome-keyring
  192. make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS"
  193. popd
  194. # perl-Git
  195. # Error.pm provide by perl-Error package
  196. rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
  197. # emacs-git
  198. mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
  199. #mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
  200. #mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
  201. mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
  202. mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
  203. # install el files
  204. install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
  205. # install vine-default file
  206. install -m644 %{SOURCE1} %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
  207. # install script( bytecompile el and install elc , remove )
  208. %_installemacsenscript git %{SOURCE10}
  209. %_removeemacsenscript git %{SOURCE11}
  210. mkdir -p $RPM_BUILD_ROOT/%{_var}/lib/git
  211. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
  212. install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
  213. perl -p \
  214. -e "s|\@GITCOREDIR\@|%{_libexecdir}/git-core|g;" \
  215. -e "s|\@BASE_PATH\@|%{_var}/lib/git|g;" \
  216. %{SOURCE3} > %{buildroot}%{_sysconfdir}/xinetd.d/git
  217. ## for gitweb sub package
  218. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
  219. install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
  220. sed "s|@PROJECTROOT@|%{_var}/lib/git|g" \
  221. %{SOURCE4} > %{buildroot}%{_sysconfdir}/gitweb.conf
  222. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  223. find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
  224. find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
  225. (find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@) > bin-man-doc-files
  226. (find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
  227. %if %{!?_without_docs:1}0
  228. (find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
  229. %else
  230. rm -rf $RPM_BUILD_ROOT%{_mandir}
  231. %endif
  232. mkdir -p $RPM_BUILD_ROOT/srv/git
  233. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
  234. install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
  235. install -m 755 contrib/diff-highlight/diff-highlight $RPM_BUILD_ROOT%{_bindir}/
  236. # header files and lib
  237. install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
  238. install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
  239. install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
  240. install libgit.a $RPM_BUILD_ROOT%{_libdir}
  241. install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
  242. # git-credential-gnome-keyring
  243. pushd contrib/credential/gnome-keyring
  244. %__install -m0755 git-credential-gnome-keyring $RPM_BUILD_ROOT%{_libexecdir}/git-core
  245. popd
  246. %find_lang %{name}
  247. %clean
  248. rm -rf $RPM_BUILD_ROOT
  249. %post -n emacs-git
  250. # bytecompile and install
  251. if [ "$1" = 2 ]; then
  252. %_emacsenPackageRemove git
  253. fi
  254. %_addemacsenlist git
  255. %_emacsenPackageInstall git
  256. %preun -n emacs-git
  257. if [ "$1" = 0 ]; then
  258. %_emacsenPackageRemove git
  259. %_removeemacsenlist git
  260. fi
  261. %files -f bin-man-doc-files -f %{name}.lang
  262. %defattr(-,root,root)
  263. %{_bindir}/git
  264. %{_bindir}/git-receive-pack
  265. %{_bindir}/git-upload-archive
  266. %{_bindir}/git-upload-pack
  267. %{_bindir}/git-shell
  268. %{_datadir}/git-core/
  269. %exclude %{_libexecdir}/git-core/git-credential-gnome-keyring
  270. %doc README.md COPYING Documentation/*.txt contrib/hooks
  271. %{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
  272. %{!?_without_docs: %doc Documentation/howto Documentation/technical}
  273. %{_sysconfdir}/bash_completion.d
  274. %files svn
  275. %defattr(-,root,root)
  276. %{_libexecdir}/git-core/*svn*
  277. %doc Documentation/*svn*.txt
  278. %{!?_without_docs: %{_mandir}/man1/*svn*.1*}
  279. %{!?_without_docs: %doc Documentation/*svn*.html }
  280. %files cvs
  281. %defattr(-,root,root)
  282. %doc Documentation/*git-cvs*.txt
  283. %{_bindir}/git-cvsserver
  284. %{_libexecdir}/git-core/*cvs*
  285. %{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
  286. %{!?_without_docs: %doc Documentation/*git-cvs*.html }
  287. %files contrib
  288. %defattr(-,root,root)
  289. %doc contrib/diff-highlight/README.diff-highlight
  290. %{_bindir}/diff-highlight
  291. %{_libexecdir}/git-core/git-credential-gnome-keyring
  292. %if "%{?_dist_release}" != "vl4" && %{with arch}
  293. %files arch
  294. %defattr(-,root,root)
  295. %doc Documentation/git-archimport.txt
  296. %{_libexecdir}/git-core/git-archimport
  297. %{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
  298. %{!?_without_docs: %doc Documentation/git-archimport.html }
  299. %endif
  300. %files email
  301. %defattr(-,root,root)
  302. %doc Documentation/*email*.txt
  303. %{_libexecdir}/git-core/*email*
  304. %{!?_without_docs: %{_mandir}/man1/*email*.1*}
  305. %{!?_without_docs: %doc Documentation/*email*.html }
  306. %files gui
  307. %defattr(-,root,root)
  308. %{_libexecdir}/git-core/git-gui*
  309. %{_libexecdir}/git-core/git-citool
  310. %{_datadir}/git-gui/
  311. %{!?_without_docs: %{_mandir}/man1/git-gui.1*}
  312. %{!?_without_docs: %doc Documentation/git-gui.html}
  313. %{!?_without_docs: %{_mandir}/man1/git-citool.1*}
  314. %{!?_without_docs: %doc Documentation/git-citool.html}
  315. %files -n gitk
  316. %defattr(-,root,root)
  317. %doc Documentation/*gitk*.txt
  318. %{_bindir}/gitk
  319. %{_datadir}/gitk
  320. %{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
  321. %{!?_without_docs: %doc Documentation/*gitk*.html }
  322. %files -n perl-Git -f perl-files
  323. %defattr(-,root,root)
  324. %files -n emacs-git
  325. %defattr(-,root,root)
  326. %{_datadir}/emacs/site-lisp/git
  327. #%{_libdir}/emacsen-common/packages/install/git
  328. #%{_libdir}/emacsen-common/packages/remove/git
  329. %{emacsen_pkgdir}/install/git
  330. %{emacsen_pkgdir}/remove/git
  331. %files daemon
  332. %defattr(-,root,root)
  333. %{_var}/lib/git
  334. %{_libexecdir}/git-core/git-daemon
  335. %config(noreplace)%{_sysconfdir}/xinetd.d/git
  336. /srv/git
  337. %files -n gitweb
  338. %defattr(-,root,root)
  339. %doc gitweb/README
  340. /var/www/git/
  341. %config(noreplace)%{_sysconfdir}/gitweb.conf
  342. %config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
  343. %files devel
  344. %defattr(644,root,root,755)
  345. %{_includedir}/git
  346. %{_libdir}/libgit.a
  347. %{_libdir}/libgit_xdiff.a
  348. %files all
  349. # No files for you!
  350. %changelog
  351. * Sat Feb 25 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.11.1-1
  352. - update to 2.11.1
  353. * Tue Dec 20 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2.11.0-1
  354. - update to 2.11.0
  355. * Fri Nov 18 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2.10.2-2
  356. - include git-credential-gnome-keyring in contrib subpackage
  357. * Mon Nov 14 2016 Toshiaki Ara <ara_t@384.jp> 2.10.2-1
  358. - update to 2.10.2
  359. - fix build error using pcre-8.12 (Vine6)
  360. * Sun May 8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.2-1
  361. - update to 2.8.2.
  362. * Tue Apr 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.6-1
  363. - update to 2.6.6.
  364. * Thu Dec 31 2015 IWAI Masaharu <iwaim.sub@gmail.com> 2.6.4-1
  365. - update to 2.6.4
  366. - add locale files
  367. * Mon Dec 29 2014 IWAI Masaharu <iwaim.sub@gmail.com> 2.2.1-1
  368. - update to 2.2.1
  369. * Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.1-2
  370. - build with Perl 5.16
  371. * Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.1-1
  372. - update to 2.0.1
  373. - add "%%bcond_with arch": no create git-arch sub package by default
  374. * Fri Apr 18 2014 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
  375. - update to 1.9.2
  376. * Sun Dec 29 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.5.2-1
  377. - update to 1.8.5.2
  378. * Thu Nov 28 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.4.4-1
  379. - update to 1.8.4.4
  380. - new sub package: contrib
  381. * Fri Feb 8 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.3-1
  382. - new upstream release
  383. * Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.2-1
  384. - new upstream release
  385. * Thu Jan 17 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.1-1
  386. - new upstream release
  387. * Thu Jan 3 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1-1
  388. - new upstream release
  389. * Wed Dec 12 2012 IWAI, Masaharu <iwai@alib.jp> 1.8.0.2-1
  390. - new upstream release
  391. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0.1-1
  392. - new upstream release
  393. * Mon Oct 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
  394. - new upstream release
  395. - enable libpcre support, add BR: pcre-devel
  396. - add /etc/gitweb.conf
  397. - add /var/lib/git for PROJECTROOT
  398. * Mon Sep 3 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.12-1
  399. - new upstream release
  400. * Fri May 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.2-1
  401. - new upstream release
  402. * Sat May 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.1-1
  403. - new upstream release
  404. * Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.4.2-1
  405. - new upstream release
  406. * Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-2vl6
  407. - build with perl 5.12.3
  408. * Mon Jan 10 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-1
  409. - new upstream release
  410. - build with openssl 1.0.0c for VineSeed
  411. * Sat Jan 1 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.4-1
  412. - new upstream release: include security fix: CVE-2010-3906
  413. * Fri Oct 1 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.3.1-1
  414. - new upstream release
  415. - drop CVE-2010-2542 patch (Patch100): upstream fixed
  416. - apply vine-default
  417. - rename Source1: git-init.el -> vine-default-git.el
  418. - add new git-init.el file (Source12)
  419. - update git-install.sh
  420. - update %%build and %%install section for gitweb subpackage
  421. - add README in gitweb subpackage
  422. * Tue Sep 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.1-2
  423. - add Patch100 for fix CVE-2010-2542 (BOF in is_git_directory)
  424. * Wed Jun 9 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.1-1
  425. - new upstream release
  426. - fix git-daemon path in git.xinetd: <BTS:VineLinux:919>
  427. - disable building of unused python remote helper libs
  428. * Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
  429. - new upstream release with security fix
  430. - drop patch10 (included in new release)
  431. * Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
  432. - new upstream release
  433. - add patch10 git daemon extra arg parsing fix
  434. * Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
  435. - fix install script for Emacs Lisp: <BTS:VineLinux:685>
  436. - update git-install.sh (Source10) using contributed patch
  437. * Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
  438. - new upstream release
  439. * Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
  440. - delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
  441. - spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
  442. - fix summary and description in daemon sub package
  443. * Sun Feb 1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
  444. - drop Error.pm: provide by perl-Error package
  445. * Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
  446. - new upstream relase
  447. - update URL tag
  448. - add Requires: perl(SVN::Core) for svn subpackage
  449. * Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
  450. - add git-shell in git package
  451. - do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
  452. * Mon Jan 5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
  453. - added BuildRequires: xmlto
  454. * Mon Jan 5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
  455. - new upstream release
  456. - add devel subpackage (see [wishes:0165])
  457. * Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
  458. - new upstream release
  459. * Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
  460. - new upstream release
  461. * Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
  462. - new upstream release
  463. * Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
  464. - use %%emacsen_pkgdir macro
  465. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
  466. - new upstream release
  467. * Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6.4-1
  468. - initial build for Vine Linux
  469. * Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
  470. - git-1.5.6.4
  471. * Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
  472. - git-1.5.6
  473. * Tue Jun 3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
  474. - use tar.bz2 instead of tar.gz
  475. * Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
  476. - git-1.5.5.3
  477. * Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
  478. - git-1.5.5.2
  479. * Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
  480. - git-1.5.5.1
  481. * Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
  482. - git-1.5.5
  483. * Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
  484. - Remove the last two requires on git-core.
  485. * Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
  486. - Remove a patch that's already upstream.
  487. * Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
  488. - git-1.5.4.5
  489. * Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
  490. - Own /etc/bash_completion.d in case bash-completion isn't installed.
  491. * Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
  492. - Include the sample hooks from contrib/hooks as docs (bug 321151).
  493. - Install the bash completion script from contrib (bug 433255).
  494. - Include the html docs in the 'core' package again (bug 434271).
  495. * Wed Mar 19 2008 James Bowes 1.5.4.4-2
  496. - Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
  497. * Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
  498. - git-1.5.4.4
  499. * Mon Mar 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
  500. - rebuild for new perl (again)
  501. * Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
  502. - Do not silently overwrite /etc/httpd/conf.d/git.conf
  503. * Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
  504. - git-1.5.4.3
  505. - Include Kristian Høgsberg's changes to rename git-core to
  506. git and git to git-all.
  507. * Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
  508. - git-1.5.4.2
  509. * Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
  510. - Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
  511. gitweb rss feeds point be commitdiffs instead of commit
  512. * Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
  513. - git-1.5.4.1
  514. * Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
  515. - rebuild for new perl
  516. * Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
  517. - Add BuidRequires on gettext.
  518. * Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
  519. - git-1.5.4
  520. * Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
  521. - git-1.5.3.8
  522. * Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
  523. - Have git metapackage require explicit versions (bug 247214)
  524. * Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
  525. - git-1.5.3.7
  526. * Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
  527. - git-1.5.3.6
  528. - git-core requires perl(Error) (bug 367861)
  529. - git-svn requires perl(Term:ReadKey) (bug 261361)
  530. - git-email requires perl-Git (bug 333061)
  531. * Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
  532. - git-Perl requires Error package
  533. * Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
  534. - git-1.5.3.4
  535. * Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
  536. - git-1.5.3.3
  537. * Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
  538. - git-1.5.3.2
  539. * Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
  540. - Include git-gui and git-citool docs
  541. * Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
  542. - git-1.5.3.1-1
  543. * Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
  544. - git-1.5.2.5-1
  545. * Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
  546. - git-1.5.2.4-1
  547. * Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
  548. - Add git-daemon and gitweb packages
  549. * Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
  550. - Add emacs-git package (#235431)
  551. * Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
  552. - git-1.5.2.2
  553. * Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
  554. - git-1.5.2.1
  555. * Sun May 13 2007 Quy Tonthat <qtonthat@gmail.com>
  556. - Added lib files for git-gui
  557. - Added Documentation/technical (As needed by Git Users Manual)
  558. * Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
  559. - Added howto files
  560. * Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
  561. - git-1.5.0.6
  562. * Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
  563. - git-1.5.0.5
  564. * Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
  565. - git-1.5.0.3
  566. * Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
  567. - BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
  568. * Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
  569. - git-1.5.0.2
  570. * Tue Feb 13 2007 Nicolas Pitre <nico@cam.org>
  571. - Update core package description (Git isn't as stupid as it used to be)
  572. * Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
  573. - Add git-gui and git-citool.
  574. * Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
  575. - no need to install manpages executable (bz 216790)
  576. - use bytes for git-cvsserver
  577. * Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
  578. - git-1.4.4.2
  579. * Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
  580. - rebuild against the new curl
  581. * Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
  582. - git-1.4.2.4
  583. * Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
  584. - git-1.4.2.3
  585. * Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
  586. - git-1.4.2.1
  587. * Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
  588. - git-1.4.2
  589. * Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
  590. - git-1.4.1
  591. * Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
  592. - git-1.4.0
  593. * Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
  594. - git-1.3.3
  595. - enable git-email building, prereqs have been relaxed
  596. * Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
  597. - git-1.3.2
  598. * Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
  599. - git-1.3.1
  600. * Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
  601. - git-1.3.0
  602. * Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
  603. - git-1.2.6
  604. * Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
  605. - git-1.2.5
  606. * Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
  607. - git-1.2.4
  608. * Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
  609. - git-1.2.3
  610. * Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
  611. - git-1.2.2
  612. * Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
  613. - git-1.2.1
  614. * Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
  615. - git-1.2.0
  616. * Wed Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
  617. - git-1.1.6
  618. * Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
  619. - git-1.1.4
  620. * Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
  621. - git-1.1.2
  622. * Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
  623. - git-1.1.1
  624. * Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
  625. - Update to latest git-1.1.0 (drop git-email for now)
  626. - Now creates multiple packages:
  627. - git-core, git-svn, git-cvs, git-arch, gitk
  628. * Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
  629. - Change subpackage names to git-<name> instead of git-core-<name>
  630. - Create empty root package which brings in all subpackages
  631. - Rename git-tk -> gitk
  632. * Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
  633. - zlib dependency fix
  634. - Minor cleanups from split
  635. - Move arch import to separate package as well
  636. * Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
  637. - Move programs with non-standard dependencies (svn, cvs, email)
  638. into separate packages
  639. * Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
  640. - parallelize build
  641. - COPTS -> CFLAGS
  642. * Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
  643. - update to 0.99.6
  644. * Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  645. - Linus noticed that less is required, added to the dependencies
  646. * Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  647. - Updated dependencies
  648. - Don't assume manpages are gzipped
  649. * Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
  650. - drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
  651. - use RPM_OPT_FLAGS in spec file, drop patch0
  652. * Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
  653. - use dist tag to differentiate between branches
  654. - use rpm optflags by default (patch0)
  655. - own %{_datadir}/git-core/
  656. * Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
  657. - update spec file to fix Buildroot, Requires, and drop Vendor
  658. * Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  659. - Redid the description
  660. - Cut overlong make line, loosened changelog a bit
  661. - I think Junio (or perhaps OSDL?) should be vendor...
  662. * Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
  663. - Add the man pages, and the --without docs build option
  664. * Thu Jul 7 2005 Chris Wright <chris@osdl.org>
  665. - initial git spec file