123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123 |
- %define pkgname Encode-Detect
- %define filelist %{pkgname}-%{version}-filelist
- %define NVR %{pkgname}-%{version}-%{release}
- %define maketest 1
- Name: perl-Encode-Detect
- Summary: Encode-Detect - An Encode::Encoding subclass that detects the encoding of data
- Version: 1.01
- Release: 2%{?_dist_release}
- Vendor: Project Vine
- Packager: tomop
- Distribution: Vine Linux
- License: Artistic
- Group: Development/Libraries
- Url: http://www.cpan.org
- BuildRoot: %{_tmppath}/%{name}-%{version}-%(id -u -n)
- Source: http://search.cpan.org//CPAN/authors/id/J/JG/JGMYERS/Encode-Detect-1.01.tar.gz
- %description
- This Perl module is an Encode::Encoding subclass that uses
- Encode::Detect::Detector to determine the charset of the input data
- and then decodes it using the encoder of the detected charset.
- It is similar to Encode::Guess, but does not require the configuration
- of a set of expected encodings. Like Encode::Guess, it only supports
- decoding--it cannot encode.
- %prep
- %setup -q -n %{pkgname}-%{version}
- chmod -R u+w %{_builddir}/%{pkgname}-%{version}
- %build
- grep -rsl '^#!.*perl' . |
- grep -v '.bak$' |xargs --no-run-if-empty \
- %__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)'
- %{__perl} Build.PL installdirs=vendor
- %{__perl} Build
- %if %maketest
- %{__perl} Build test
- %endif
- %install
- [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
- %{__perl} Build install destdir=%{buildroot}
- cmd=/usr/share/spec-helper/compress_files
- [ -x $cmd ] || cmd=/usr/lib/rpm/brp-compress
- [ -x $cmd ] && $cmd
- if [ -e /etc/SuSE-release -o -e /etc/UnitedLinux-release ]
- then
- %{__mkdir_p} %{buildroot}/var/adm/perl-modules
- %{__cat} `find %{buildroot} -name "perllocal.pod"` \
- | %{__sed} -e s+%{buildroot}++g \
- > %{buildroot}/var/adm/perl-modules/%{name}
- fi
- find %{buildroot} -name "perllocal.pod" \
- -o -name ".packlist" \
- -o -name "*.bs" \
- |xargs -i rm -f {}
- find %{buildroot}%{_prefix} \
- -type d -depth \
- -exec rmdir {} \; 2>/dev/null
- %{__perl} -MFile::Find -le '
- find({ wanted => \&wanted, no_chdir => 1}, "%{buildroot}");
- print "%doc src include Changes LICENSE";
- for my $x (sort @dirs, @files) {
- push @ret, $x unless indirs($x);
- }
- print join "\n", sort @ret;
- sub wanted {
- return if /auto$/;
- local $_ = $File::Find::name;
- my $f = $_; s|^\Q%{buildroot}\E||;
- return unless length;
- return $files[@files] = $_ if -f $f;
- $d = $_;
- /\Q$d\E/ && return for reverse sort @INC;
- $d =~ /\Q$_\E/ && return
- for qw|/etc %_prefix/man %_prefix/bin %_prefix/share|;
- $dirs[@dirs] = $_;
- }
- sub indirs {
- my $x = shift;
- $x =~ /^\Q$_\E\// && $x ne $_ && return 1 for @dirs;
- }
- ' > %filelist
- [ -z %filelist ] && {
- echo "ERROR: empty %files listing"
- exit -1
- }
- %clean
- [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
- %files -f %filelist
- %defattr(-,root,root)
- %changelog
- * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 1.01-2
- - rebuild with gcc-5.4.0
- * Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.01-1
- - initial build for Vine Linux.
|