json-c-vl.spec 1.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788
  1. %define pkg_version 0.9
  2. %define pkg_release 1%{?_dist_release}
  3. Summary: A JSON implementation in C
  4. Name: json-c
  5. Version: %{pkg_version}
  6. Release: %{pkg_release}
  7. Source0: http://oss.metaparadigm.com/json-c/%{name}-%{version}.tar.gz
  8. License: MIT
  9. Group: System Environment/Libraries
  10. URL: http://oss.metaparadigm.com/json-c/
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. Packager: Takemikaduchi
  15. %description
  16. JSON-C implements a reference counting object model that allows you to easily
  17. construct JSON objects in C, output them as JSON formatted strings and parse
  18. JSON formatted strings back into the C representation of JSON objects.
  19. %package devel
  20. Summary: Development files for json-c
  21. Group: Development/Libraries
  22. Requires: %{name} = %{version}-%{release}
  23. Requires: pkgconfig
  24. %description devel
  25. This package contains the libraries and header files that are needed
  26. for writing applications that are using json-c.
  27. %package doc
  28. Summary: Documentation for json-c
  29. Group: Documentation
  30. Requires: %{name} = %{version}-%{release}
  31. BuildArch: noarch
  32. %description doc
  33. This package contains documentation for json-c.
  34. %prep
  35. %setup -q
  36. %build
  37. %configure --disable-static
  38. %{__make} %{?_smp_mflags}
  39. %install
  40. %{__rm} -rf $RPM_BUILD_ROOT
  41. %{__make} install DESTDIR=$RPM_BUILD_ROOT
  42. %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/*.la
  43. %clean
  44. %{__rm} -rf $RPM_BUILD_ROOT
  45. %post -p /sbin/ldconfig
  46. %postun -p /sbin/ldconfig
  47. %files
  48. %defattr(-,root,root,-)
  49. %doc COPYING ChangeLog COPYING NEWS README README.html
  50. %{_libdir}/libjson.so.*
  51. %files devel
  52. %defattr(-,root,root,-)
  53. %{_includedir}/json/*
  54. %{_libdir}/libjson.so
  55. %{_libdir}/pkgconfig/json.pc
  56. %files doc
  57. %defattr(-,root,root,-)
  58. %doc doc/html/*
  59. %changelog
  60. * Fri Oct 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9-1
  61. - initial build for Vine Linux