gnome-shell-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200
  1. %define pkg_version 3.1.92
  2. %define pkg_release 1%{?_dist_release}
  3. Summary: Window management and application launching for GNOME
  4. Name: gnome-shell
  5. Version: %{pkg_version}
  6. Release: %{pkg_release}
  7. Source0: %{name}-%{version}.tar.xz
  8. # settings for Vine
  9. Patch101: gnome-shell-vine-settings.patch
  10. Patch102: gnome-shell-vine-customize.patch
  11. Patch103: gnome-shell-3.1.91.1-ja.po.patch
  12. License: GPLv2+
  13. Group: User Interface/Desktops
  14. URL: http://live.gnome.org/GnomeShell
  15. Requires(post,postun): scrollkeeper >= 0.1.4
  16. Requires(post,pre,preun): GConf2 >= 2.14
  17. Requires: mutter
  18. Requires: caribou
  19. Requires: openssl
  20. BuildRequires: gnome-common
  21. BuildRequires: libtool
  22. BuildRequires: automake
  23. BuildRequires: autoconf
  24. BuildRequires: pkgconfig
  25. BuildRequires: gtk2-devel
  26. BuildRequires: clutter-devel
  27. BuildRequires: mutter-devel
  28. BuildRequires: gjs-devel
  29. BuildRequires: gnome-desktop3-devel
  30. BuildRequires: gnome-menus-devel
  31. BuildRequires: libSM-devel
  32. BuildRequires: libffi-devel
  33. BuildRequires: GConf2-devel
  34. BuildRequires: startup-notification-devel
  35. BuildRequires: gnome-doc-utils
  36. BuildRequires: desktop-file-utils
  37. BuildRequires: libcroco-devel
  38. BuildRequires: librsvg2-devel
  39. BuildRequires: gobject-introspection-devel
  40. BuildRequires: gstreamer-devel
  41. BuildRequires: dbus-glib-devel
  42. BuildRequires: telepathy-logger-devel
  43. BuildRequires: polkit-devel
  44. BuildRequires: pulseaudio-libs-devel
  45. BuildRequires: evolution-data-server-devel
  46. BuildRequires: folks-devel
  47. BuildRequires: NetworkManager-glib-devel
  48. BuildRequires: libgudev1-devel
  49. BuildRequires: openssl
  50. BuildRequires: intltool
  51. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  52. Vendor: Project Vine
  53. Distribution: Vine Linux
  54. Packager: Takemikaduchi
  55. %description
  56. GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
  57. It provides core interface functions like switching to windows and launching
  58. applications. GNOME Shell takes advantage of the capabilities of modern graphics
  59. hardware and introduces innovative user interface concepts to provide a delightful
  60. and easy to use experience.
  61. %prep
  62. %setup -q
  63. %patch101 -p1 -b .vine
  64. %patch102 -p1 -b .vine
  65. %patch103 -p1 -b .old_po
  66. %build
  67. libtoolize --copy --force
  68. autoreconf
  69. %configure \
  70. --disable-static \
  71. --with-ca-certificates=%{_datadir}/ssl/certs/ca-bundle.crt
  72. %{__make} %{?_smp_mflags}
  73. %install
  74. %{__rm} -rf ${RPM_BUILD_ROOT}
  75. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  76. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  77. %find_lang %{name}
  78. %clean
  79. %{__rm} -rf ${RPM_BUILD_ROOT}
  80. %post
  81. /sbin/ldconfig
  82. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  83. gconftool-2 --makefile-install-rule \
  84. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
  85. > /dev/null || :
  86. touch --no-create %{_datadir}/icons/hicolor
  87. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  88. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  89. fi
  90. %pre
  91. if [ "$1" -gt 1 ]; then
  92. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  93. gconftool-2 --makefile-uninstall-rule \
  94. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
  95. > /dev/null || :
  96. fi
  97. %preun
  98. if [ "$1" -eq 0 ]; then
  99. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  100. gconftool-2 --makefile-uninstall-rule \
  101. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
  102. > /dev/null || :
  103. fi
  104. %postun
  105. scrollkeeper-update -q || :
  106. /sbin/ldconfig
  107. touch --no-create %{_datadir}/icons/hicolor
  108. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  109. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  110. fi
  111. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  112. %posttrans
  113. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  114. %files -f %{name}.lang
  115. %defattr(-,root,root)
  116. %doc COPYING NEWS README
  117. %{_sysconfdir}/gconf/schemas/gnome-shell.schemas
  118. %{_bindir}/gnome-shell
  119. %{_bindir}/gnome-shell-extension-tool
  120. %{_libdir}/gnome-shell/*
  121. %{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
  122. %{_libexecdir}/gnome-shell-calendar-server
  123. %{_libexecdir}/gnome-shell-hotplug-sniffer
  124. %{_libexecdir}/gnome-shell-perf-helper
  125. %{_datadir}/applications/gnome-shell.desktop
  126. %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
  127. %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
  128. %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
  129. %{_datadir}/gnome-shell/*
  130. %{_datadir}/man/man1/*.1.gz
  131. %changelog
  132. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  133. - new upstream release
  134. - update Patch101
  135. - update Patch102
  136. - update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
  137. - add BuildRequires: libgudev1-devel, openssl
  138. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
  139. - new upstream release
  140. - add BuildRequires: folks-devel, NetworkManager-glib-devel
  141. - add Requires: caribou
  142. - remove Patch0
  143. - update Patch101
  144. - update Patch102
  145. - update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
  146. * Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
  147. - rebuild with gnome-menus-3.1.5
  148. - add Patch0 (gnome-shell-git20110821.patch)
  149. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  150. - new upstream release
  151. - add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
  152. - change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
  153. - remove BuildRequires: xulrunner-devel
  154. - add Patch101 (gnome-shell-vine-settings.patch)
  155. - add Patch102 (gnome-shell-vine-customize.patch)
  156. - add Patch103 (gnome-shell-3.1.4-ja.po.patch)
  157. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
  158. - add Requires: mutter
  159. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
  160. - new upstream release
  161. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  162. - initial build for Vine Linux