123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143 |
- # A header-only library has no debuginfo
- %global debug_package %{nil}
- Name: py3c
- Version: 1.3
- Release: 4%{?_dist_release}
- Summary: Guide and compatibility macros for porting extensions to Python 3
- Group: programming
- Vendor: Project Vine
- Distribution: Vine Linux
- # Licences differ for subpackages
- License: MIT and CC-BY-SA
- URL: http:
- Source0: https:
- BuildRequires: make
- BuildRequires: gcc
- BuildRequires: python3-devel
- BuildRequires: python3-setuptools
- %description
- py3c helps you port C extensions to Python 3.
- It provides a detailed guide, and a set of macros to make porting easy
- and reduce boilerplate.
- %package devel
- Summary: Header files for py3c
- License: MIT
- Group: programming
- Requires: python3-devel
- # A header-only library counts as static
- Provides: %{name}-static = %{version}-%{release}
- %{?_isa:Provides: %{name}-static%{?_isa} = %{version}-%{release}}
- %description devel
- %{name}-devel is only required for building software that uses py3c.
- Because py3c is a header-only library, there is no matching run-time package.
- %prep
- %setup -q
- %build
- make %{?_smp_mflags} py3c.pc includedir=%{_includedir}
- %install
- make install prefix=%{buildroot}%{_prefix} includedir=%{buildroot}%{_includedir}
- # Strip buildroot name from the pkgconfig file
- sed --in-place -e's!%{buildroot}!!' %{buildroot}%{_datadir}/pkgconfig/py3c.pc
- %check
- export CFLAGS="%{optflags}"
- make %{?_smp_mflags} test-python3
- %files devel
- %license LICENSE.MIT
- %doc README.rst
- %{_includedir}/py3c.h
- %{_includedir}/py3c/
- %{_datadir}/pkgconfig/py3c.pc
- %changelog
- * Fri Mar 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.3-4
- - initial build for Vine Linux.
- * Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.3-3
- - Rebuilt for https:
- * Thu Jan 07 2021 Petr Viktorin <pviktori@redhat.com> - 1.3-2
- - No longer unbundle fonts
- * Sun Nov 29 2020 Petr Viktorin <pviktori@redhat.com> - 1.3-1
- - Update to 1.3
- * Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.2-2
- - Rebuilt for https:
- * Thu Jan 30 2020 Petr Viktorin <pviktori@redhat.com> - 1.2-1
- - Update to 1.2 to fix tests under Python 3.9
- - BuildRequire python3-setuptools explicitly
- * Thu Jan 30 2020 Petr Viktorin <pviktori@redhat.com> - 1.1-3
- - Drop tests and Suggests for Python 2; require python3-devel
- * Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1-2
- - Rebuilt for https:
- * Fri Oct 04 2019 Petr Viktorin <pviktori@redhat.com> - 1.1-1
- - Update to 1.1 to fix Python 3.8 compatibility in tests
- https:
- * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0-6
- - Rebuilt for https:
- * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0-5
- - Rebuilt for https:
- * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0-4
- - Rebuilt for https:
- * Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 1.0-3
- - Rebuilt for Python 3.7
- * Mon Feb 19 2018 Petr Viktorin <pviktori@redhat.com> - 1.0-2
- - Add BuildRequires: gcc
- * Sun Feb 11 2018 Petr Viktorin <pviktorin@redhat.com> - 1.0-1
- - Update to 1.0 (adds Py_UNREACHABLE, Py_RETURN_RICHCOMPARE, Py_UNUSED)
- - Strip buildroot name from the pkgconfig file
- * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.8-5
- - Rebuilt for https:
- * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.8-4
- - Rebuilt for https:
- * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.8-3
- - Rebuilt for https:
- * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.8-2
- - Rebuilt for https:
- * Wed Feb 01 2017 Petr Viktorin <pviktorin@redhat.com> - 0.8-1
- - Update to 0.8:
- - Add backports for PyMem_Raw*
- * Thu May 19 2016 Petr Viktorin <pviktorin@redhat.com> - 0.7-1
- - Update to 0.7:
- - Fix file shim tests on big endian architectures
- (bug in the test suite only, does not affect behavior)
- * Thu May 19 2016 Petr Viktorin <pviktorin@redhat.com> - 0.6-2
- - Initial package
|