mozc-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229
  1. %define ver 0.11.0
  2. %define rel 7
  3. %define svnrev 28
  4. %define utdic 20100601
  5. %define enable_utdic_meisi 0
  6. %define enable_utdic_jigyosyo 0
  7. %define enable_edict_katakanago 0
  8. Name: mozc
  9. Summary: Japanese Input Method Editor designed for multi-platform
  10. Summary(ja): マルチプラットホームで動くように設計された日本語インプットメソッドエディタ
  11. Version: 0.11.0
  12. Release: %{rel}.svn%{svnrev}%{?_dist_release}
  13. Group: System Environment/Libraries
  14. License: BSD-like (and EDICT is CC-by-sa 3.0 Unported)
  15. URL: http://code.google.com/p/mozc/
  16. # Source tar ball is not released yet.
  17. # See http://code.google.com/p/mozc/wiki/LinuxBuildInstructions
  18. Source0: %{name}-%{version}-r%{svnrev}.tar.bz2
  19. # Additional dictionaries by UTUMI Hirosi
  20. Source1: mozcdic-ut-%{utdic}.tar.bz2
  21. # http://twitpic.com/1ouyrr by AWASHIRO Ikuya
  22. Source3: ibus-mozc.png
  23. # http://twitpic.com/1t0zkb by AWASHIRO Ikuya
  24. Source4: ibus-mozc-unknown.png
  25. # Vine Lunux
  26. Source10: README.vine
  27. #Patch0: ibus-mozc-fix-for-x86_64.diff
  28. Patch1: ibus-mozc-0.11.0-fix-compile-w-i386.patch
  29. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  30. BuildRequires: python, ibus-devel, dbus-devel
  31. BuildRequires: openssl-devel, zlib-devel, subversion
  32. BuildRequires: curl-devel
  33. BuildRequires: protobuf-devel, gtest-devel
  34. BuildRequires: qt4-devel
  35. Requires: mozc-server = %{version}-%{release}
  36. Requires: mozc-utils-gui = %{version}-%{release}
  37. Requires: ibus-mozc = %{version}-%{release}
  38. Packager: kazutaka
  39. %description
  40. Mozc is a Japanese Input Method Editor (IME) designed for
  41. multi-platform such as Chromium OS, Windows, Mac and Linux.
  42. This open-source project originates from Google Japanese Input.
  43. %description -l ja
  44. Mozc は日本語入力用の IME (Imput Method Editor)です。
  45. Chromium OS や Windows、Mac、Linux といったマルチプラット
  46. フォームで利用できるようにデザインされており、「Google日本語
  47. 入力」のオープンソース版です。
  48. %package server
  49. Summary: Server part of the Mozc input method
  50. Summary(ja): Mozc インプットメソッドのサーバ部分
  51. Group: Applications/System
  52. %description server
  53. Server part of the Mozc input method, used by Mozc clients such as
  54. ibus-mozc.
  55. %description server -l ja
  56. Mozc インプットメソッドのサーバ部分。ibus-mozcなどのMozcクライアントから
  57. 使うことができます。
  58. %package -n ibus-mozc
  59. Summary: iBus engine module for Mozc
  60. Summary(ja): Mozc 用 iBus エンジンモジュール
  61. Group: System Environment/Libraries
  62. Requires: mozc-server = %{version}-%{release}
  63. %description -n ibus-mozc
  64. iBus engine module for Mozc.
  65. %description -n ibus-mozc -l ja
  66. Mozc 用 iBus エンジンモジュール。
  67. %package utils-gui
  68. Summary: Mozc GUI utilities
  69. Summary(ja): Mozc GUI ユーティリティー
  70. Group: Applications/System
  71. Requires: qt4
  72. Requires: mozc-server = %{version}-%{release}
  73. %description utils-gui
  74. Mozc GUI uitilities, such as the configuration dialog, user dictionary
  75. tool and about dialog.
  76. %description utils-gui -l ja
  77. Mozc GUI ユーティリティー。設定ツールやユーザ辞書ツールなどが含まれます。
  78. %prep
  79. %setup -q -n %{name}-%{version}-r%{svnrev} -a 1
  80. #%patch0 -p0 -b .fix-x86_64
  81. %patch1 -p1 -b .fix-i386
  82. # Add some dictionaries
  83. pushd mozcdic-ut-%{utdic}
  84. %{__cp} mozcdic-ut-jinmei-*.txt ../data/dictionary/
  85. %{__cp} mozcdic-ut-zipcode-*.txt ../data/dictionary/
  86. %{__cp} mozcdic-ut-meisi-*.txt ../data/dictionary/
  87. %{__cp} mozcdic-ut-jigyosyo-*.txt ../data/dictionary/
  88. %{__cp} edict-katakanago/mozcdic-ut-edict-katakanago-*.txt ../data/dictionary/
  89. popd
  90. pushd data/dictionary/
  91. %{__cat} dictionary1.txt mozcdic-ut-jinmei-*.txt mozcdic-ut-zipcode-*.txt > dictionary1.txt.new
  92. %if %{enable_utdic_meisi}
  93. %{__cat} mozcdic-ut-meisi-*.txt >> dictionary1.txt.new
  94. %endif
  95. %if %{enable_utdic_jigyosyo}
  96. %{__cat} mozcdic-ut-jigyosyo-*.txt >> dictionary1.txt.new
  97. %endif
  98. %if %{enable_edict_katakanago}
  99. %{__cat} mozcdic-ut-edict-katakanago-*.txt >> dictionary1.txt.new
  100. %endif
  101. %{__mv} dictionary1.txt.new dictionary1.txt
  102. popd
  103. %build
  104. %{__python} build_mozc.py gyp
  105. %{__python} build_mozc.py build_tools -c Release
  106. %{__python} build_mozc.py build -c Release unix/ibus/ibus.gyp:ibus_mozc server/server.gyp:mozc_server gui/gui.gyp:mozc_tool
  107. %install
  108. %{__rm} -rf %buildroot
  109. %{__mkdir_p} %buildroot/%{_libdir}
  110. %{__cp} -p out/Release/ibus_mozc %buildroot/%{_libdir}/ibus-engine-mozc
  111. %{__mkdir_p} %buildroot/%{_datadir}/ibus/component/
  112. %{__sed} 's|/usr/libexec|%{_libdir}|' < unix/ibus/mozc.xml > %buildroot/%{_datadir}/ibus/component/mozc.xml
  113. # mozc-server
  114. %{__mkdir_p} %buildroot/%{_libdir}/mozc
  115. %{__cp} -p out/Release/mozc_server %buildroot/%{_libdir}/mozc
  116. # mozc_tool
  117. %{__cp} -p out/Release/mozc_tool %buildroot/%{_libdir}/mozc
  118. # install icon (temporary)
  119. %{__mkdir_p} %{buildroot}%{_datadir}/ibus-mozc
  120. %{__cp} -p %{SOURCE3} %{buildroot}%{_datadir}/ibus-mozc/product_icon.png
  121. %{__cp} -p %{SOURCE4} %{buildroot}%{_datadir}/ibus-mozc/unknown.ico
  122. # install document
  123. %{__chmod} 644 debian/*
  124. %{__cp} debian/copyright COPYING
  125. %{__cp} %{SOURCE10} .
  126. %{__mkdir} utdic
  127. %{__cp} mozcdic-ut-%{utdic}/{AUTHORS,COPYING,ChangeLog,README} utdic
  128. %{__mkdir} edict
  129. %{__cp} mozcdic-ut-%{utdic}/edict-katakanago/README.edict edict
  130. %clean
  131. rm -rf $RPM_BUILD_ROOT
  132. %files
  133. %defattr(-,root,root)
  134. %doc COPYING README.vine utdic edict
  135. %files server
  136. %defattr(-,root,root)
  137. %doc COPYING README.vine utdic edict
  138. %dir %{_libdir}/mozc
  139. %{_libdir}/mozc/mozc_server
  140. %files utils-gui
  141. %defattr(-,root,root)
  142. %doc COPYING
  143. %dir %{_libdir}/mozc
  144. %{_libdir}/mozc/mozc_tool
  145. %files -n ibus-mozc
  146. %defattr(-,root,root)
  147. %doc COPYING
  148. %{_libdir}/ibus-engine-mozc
  149. %{_datadir}/ibus/component/mozc.xml
  150. %dir %{_datadir}/ibus-mozc
  151. %{_datadir}/ibus-mozc/product_icon.png
  152. %{_datadir}/ibus-mozc/unknown.ico
  153. %changelog
  154. * Wed Jun 2 2010 IWAI, Masaharu <iwai@alib.jp> 0.11.0-7.svn28
  155. - add mozc_tool's icon (Source4)
  156. - rename Source0: fixed created directory name "src"
  157. * Tue Jun 1 2010 IWAI, Masaharu <iwai@alib.jp> 0.11.0-6.svn28
  158. - update mozcdic-ut 20100601 (Source10)
  159. - include documents for all dictionaries
  160. - add BuildRequires: qt4-devel
  161. * Tue Jun 1 2010 IWAI, Masaharu <iwai@alib.jp> 0.11.0-5.svn28
  162. - rename base name: mozc
  163. - add new sub packages:
  164. - mozc-server
  165. - mozc-utils-gui
  166. - update source to revision 28
  167. - replace icon (Source3)
  168. - drop mozc-config: upstream implement same tool
  169. * Sun May 23 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.11.0-4
  170. - update source to revision 23
  171. - add BuildRequires protobuf-devel, gtest-devel
  172. - drop Patch0 (ibus-mozc-fix-for-x86_64.diff)
  173. - add mozc-config as Source10 and desktop entry as Source11
  174. * Sat May 15 2010 IWAI, Masaharu <iwai@alib.jp> 0.11.0-3
  175. - rebuild with ibus-1.3.3
  176. * Fri May 14 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.11.0-2
  177. - add Patch1 to fix compile error on i386 (workaround patch)
  178. * Thu May 13 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.11.0-1
  179. - initial build for Vine Liux based on custom mandriva package made by UTUMI-san
  180. * Thu May 13 2010 UTUMI Hirosi <utuhiro78@yahoo.co.jp> 0.11.0-2.20110511.1mdv2010.1
  181. - add some dictionaries
  182. * Wed May 12 2010 UTUMI Hirosi <utuhiro78@yahoo.co.jp> 0.11.0-1.20110511.1mdv2010.1
  183. - first release