%define	tarball_id	g567042d
%define	source_id	bebd4db

Summary:	Java graph visualisation library
Summary(ja):	Java グラフ可視化ライブラリ
Name:		jgraphx
Version:	1.10.4.0
Release:	1%{?_dist_release}
Group:		Development/Libraries
License:	BSD
URL:		http://www.jgraph.com/
Source:		http://downloads.jgraph.com/downloads/jgraphx/archive/%{name}-1_10_4_0.zip

BuildRequires:	ant
BuildRequires:	java-devel >= 1.6.0
BuildRequires:	jpackage-utils

Requires:		java >= 1.6.0
Requires:		jpackage-utils

BuildArch:		noarch

%description
JGraphX provides functionality for visualisation and interaction
with node-edge graphs (not charts). Example applications that you
might write with it are a workflow editor, an organisational chart,
a business process modelling tool, a UML tool, an electronic circuit
diagrammer, network/telecoms visualisation (you get the idea, things
with nodes and edges that connect those nodes, a mathematical graph).

%package javadoc
Summary:        API Documentation for %{name}
Group:          Documentation
Requires:       jpackage-utils
Requires:       %{name} = %{version}-%{release}

%description javadoc
JavaDoc documentation for %{name}


%prep
%setup -q -n %{name}
find -name '*.jar' -delete
rm -rf docs/api


%build
ant


%install

# Code
install -d $RPM_BUILD_ROOT%{_javadir}
install -p -m644 lib/%{name}.jar \
$RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
ln -s %{name}-%{version}.jar \
$RPM_BUILD_ROOT%{_javadir}/%{name}.jar

# API documentation
install -d $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
cp -a docs/api/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}


%files
%{_javadir}/*
%doc license.txt

%files javadoc
%{_javadocdir}/*


%changelog
* Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4.0-1
- initial build