## -*- coding: utf-8-unix -*-
## NOTE: This spec file is generated by tlpdb2rpmspec 2014-2: 
## tlpdb2rpmspec collection-htmlxml

%global _use_internal_dependency_generator 0
%global __find_provides %{nil}
%global __find_requires %{nil}

Summary: TeX Live: HTML/SGML/XML support
Summary(ja): TeX Live: HTML/SGML/XML support
Name: texlive-collection-htmlxml
Version: 2014
Release: 2%{?_dist_release}
License: LPPL 1.3, Freely redistributable without restriction, LPPL
Group: Applications/Publishing
URL:http://www.tug.org/texlive/

Source0: classpack.doc.tar.xz
Source1: classpack.source.tar.xz
Source2: classpack.tar.xz
Source3: jadetex.doc.tar.xz
Source4: jadetex.source.tar.xz
Source5: jadetex.tar.xz
Source6: passivetex.tar.xz
Source7: tex4ht.doc.tar.xz
Source8: tex4ht.tar.xz
Source9: xmltex.doc.tar.xz
Source10: xmltex.tar.xz

Requires: texlive = %{version}
Requires: texlive-collection-basic = %{version}
Requires: texlive-collection-fontsrecommended = %{version}
Requires: texlive-collection-latex = %{version}

Requires(post):		texlive = %{version}
Requires(postun):	texlive = %{version}

BuildArch:	noarch
Buildroot:	%{_tmppath}/%{name}-%{version}-root

Vendor:		Project Vine
Distribution:	Vine Linux
Packager:	munepi

%description
The TeX Live software distribution offers a complete TeX system for a
variety of Unix, Macintosh, Windows and other platforms. It
encompasses programs for editing, typesetting, previewing and printing
of TeX documents in many different languages, and a large collection
of TeX macros and font libraries.

The distribution includes extensive general documentation about TeX,
as well as the documentation for the included software packages.

This package is a collection of HTML/SGML/XML support: 
Packages to convert LaTeX to XML/HTML, and typset XML/SGML.

This package contains the following CTAN packages: 
classpack: XML mastering for LaTeX classes and packages.
jadetex: Macros supporting Jade DSSSL output.
passivetex: Support package for XML/SGML typesetting
tex4ht: Convert (La)TeX to HTML/XML.
xmltex: Support for parsing XML documents.

%description -l ja
TeX Live ソフトウェアディストリビューションは、
さまざまな Unix, Macintosh, Windows、および
他のプラットホームに対して完全な TeX システムを提供します。
多くの異なった言語を含む TeX ドキュメントの
編集、組版、閲覧、印刷するためのプログラム、
そして、TeX マクロやフォントライブラリの大きなコレクションを
同梱しています。

このディストリビューションは
同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
TeX に関するたくさんの一般的なドキュメントを含んでいます。

このパッケージは以下のようなパッケージ集です。
HTML/SGML/XML support: 
Packages to convert LaTeX to XML/HTML, and typset XML/SGML.

このパッケージは以下の CTAN パッケージを含んでいます: 
classpack: XML mastering for LaTeX classes and packages.
jadetex: Macros supporting Jade DSSSL output.
passivetex: Support package for XML/SGML typesetting
tex4ht: Convert (La)TeX to HTML/XML.
xmltex: Support for parsing XML documents.

%package doc
Summary: TeX Live: Documentation files of %{name}
Group: Applications/Publishing
Requires: %{name} = %{version}-%{release}

%description doc
This package contains documentation files of %{name}.

%prep
%setup -c -n %{name}-%{version}
%__tar -xvf %{SOURCE1}
%__tar -xvf %{SOURCE2}
%__tar -xvf %{SOURCE3}
%__tar -xvf %{SOURCE4}
%__tar -xvf %{SOURCE5}
%__tar -xvf %{SOURCE6}
%__tar -xvf %{SOURCE7}
%__tar -xvf %{SOURCE8}
%__tar -xvf %{SOURCE9}
%__tar -xvf %{SOURCE10}

%build

%install
[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}

%__mkdir_p %{buildroot}%{_datadir}

## move texmf-dist to /usr/share/texmf-dist
[ -d texmf-dist ] && %__mv texmf-dist %{buildroot}%{_tl_texmfdist}/ ||:

## move texmf to /usr/share/texmf
[ -d texmf ] && %__mv texmf %{buildroot}%{_tl_texmfmain}/ ||:

## move tlpkg to /usr/share/tlpkg
[ -d tlpkg ] && %__mv tlpkg %{buildroot}%{_datadir}/ ||:

## move all non-arch binaries to /usr/bin
[ -d bin ] && %__mv bin %{buildroot}%{_prefix}/ ||:

## move others into /usr/share/texmf-dist
%__mkdir_p %{buildroot}%{_tl_texmfdist}
%__cp -a * %{buildroot}%{_tl_texmfdist}/ ||:
%__rm -rf * ||:


## remove duplicated files between texlive and texlive-collection-*
## NOTE: We provides texmf.cnf and updmap{-hdr,}.cfg from texlive
## remove unpacked files
x=(
scripts/texlive/fmtutil.sh
texconfig/tcfmgr
web2c/texmf.cnf
web2c/updmap-hdr.cfg
web2c/updmap.cfg
install-tl
)
if [ -d %{buildroot}%{_tl_texmfdist} ]; then
pushd %{buildroot}%{_tl_texmfdist}
%__rm -f ${x[@]} ||:
popd
fi

## Files list
find %{buildroot} -type f -or -type l | \
    %__sed -e "s|%{buildroot}||g" > filelist.full

find %{buildroot}%{_tl_texmfdist} -type d | \
    %__sed -e "s|^%{buildroot}|%dir |" \
           -e "s|$|/|"             >> filelist.full

## subpackages
grep "/texmf-dist/doc/" filelist.full > filelist.doc
cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
%__mv -f filelist.tmp filelist.full

%clean
%__rm -rf %{buildroot}

%post
%_tl_touch_run texhash
%_tl_touch_run mtxrun

%_tl_touch_run fmtutil

exit 0


%postun
if [ "$1" = 0 ]; then
    %_tl_touch_run texhash

fi

exit 0

%posttrans
%{_tl_exec_texhash}
%{_tl_exec_mtxrun}
%{_tl_exec_updmap}
%{_tl_exec_fmtutil}
exit 0


%files -f filelist.full
%defattr(-,root,root,-)

%files -f filelist.doc doc
%defattr(-,root,root,-)

%changelog
* Sun Jul  6 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-2
- synced tlnet to 20140706

* Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-1
- synced tlnet to 20140524